2 Replies Latest reply on Apr 24, 2014 11:46 AM by Shawn Schellinger

    Camel ActiveMQ Broker Fuse Deployment Issue

    Shawn Schellinger Newbie

      I tried deploying an ActiveMQ Camel project to Fuse 6.1 (379) and am seeing some GracePeriod-related issues.  I fear I am introducing an error in my Camel route, POM dependencies, etc.  Here are my details.

       

      I am using Blueprint.  These are the important items I added/changed to my Camel context to add a JMS broker.  Prior to these additions, everything worked fine:

       

      Namespace:  xmlns:broker="http://activemq.apache.org/schema/core"

      schemaLocationhttp://activemq.apache.org/schema/core http://activemq.apache.org/schema/core/activemq-core.xsd

       

      Broker:

       

        <broker:broker useJmx="false" persistent="true" brokerName="amqBroker">

          <broker:transportConnectors>

            <broker:transportConnector uri="tcp://${activeMQ.url}"/>

          </broker:transportConnectors>

        </broker:broker>

       

      AMQ JMS Component:


        <bean id="activemq" class="org.apache.camel.component.jms.JmsComponent">

          <property name="connectionFactory">

            <bean class="org.apache.activemq.ActiveMQConnectionFactory">

              <property name="brokerURL" value="tcp://amqBroker:61616" />

              <property name="userName" value="${activeMQ.username}" />

              <property name="password" value="${activeMQ.password}" />

            </bean>

          </property>

        </bean>

       

      I believe I have added all of the necessary dependencies in the POM as the Maven build works fine.  After I deploy my project, I see no errors, but I see the following in the Fuse log (notice the bolded item):

       

      11:44:27,637 | INFO  | edhat-379/deploy | fileinstall                  | 7 - org.apache.felix.fileinstall - 3.3.11.redhat-610379 | Installed C:\apps\jboss-fuse-6.1.0.redhat-379\deploy\camel-cxf-contract-first-blueprint-1.0.0-SNAPSHOT.jar
      11:44:27,711 | INFO  | edhat-379/deploy | BlueprintContainerImpl       | 9 - org.apache.aries.blueprint.core - 1.0.1.redhat-610379 | Bundle camel-cxf-contract-first-blueprint is waiting for namespace handlers [http://activemq.apache.org/schema/core]
      11:44:27,713 | INFO  | edhat-379/deploy | fileinstall                  | 7 - org.apache.felix.fileinstall - 3.3.11.redhat-610379 | Started bundle: file:/C:/apps/jboss-fuse-6.1.0.redhat-379/deploy/camel-cxf-contract-first-blueprint-1.0.0-SNAPSHOT.jar

       

      And here is what I see when I do an osgi:list (notice the bolded text):

       

      [ 254] [Active ] [GracePeriod ] [   ] [   60] A Camel CXF Blueprint Route (1.0.0.SNAPSHOT)

       

      I am at a loss.  Is there a different namespace I'm supposed to be using for Blueprint?  I can send my entire Camel Context and POM if necessary, but didn't want to clutter up this message.  Thanks for your help.

       

      Shawn