7 Replies Latest reply on Jul 30, 2014 10:29 AM by Rob Cernich

    Unable to use switchyard tooling after upgrade to latest version

    Aaron Cirillo Newbie

      I upgraded my switchyard tooling to version 1.1.5.v20140403-2328-H5-Final. After the upgrade I am no longer able to create swtichyard projects or work at all with the switchyard tooling.

       

      This is the error I get in my JBDS log when attempting to create a new switchyard project:

       

      !ENTRY org.eclipse.e4.ui.css.swt 4 0 2014-04-24 12:22:19.274

      !MESSAGE Failed to get bundle for: bundleclass://net.jeeeyul.eclipse.themes/net.jeeeyul.eclipse.themes.rendering.JeeeyulsTabRenderer

       

       

      !ENTRY org.eclipse.e4.ui.css.swt 4 0 2014-04-24 12:22:19.275

      !MESSAGE Failed to get bundle for: bundleclass://net.jeeeyul.eclipse.themes/net.jeeeyul.eclipse.themes.rendering.JeeeyulsTabRenderer

       

       

      !ENTRY org.eclipse.ui 4 0 2014-04-24 12:22:22.397

      !MESSAGE Unhandled event loop exception

      !STACK 0

      java.lang.NoClassDefFoundError: org/sonatype/aether/version/InvalidVersionSpecificationException

        at org.switchyard.tools.ui.wizards.NewSwitchYardProjectWizard.addPages(NewSwitchYardProjectWizard.java:98)

        at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:605)

        at org.eclipse.jface.window.Window.create(Window.java:432)

        at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1104)

        at org.eclipse.ui.internal.navigator.wizards.WizardShortcutAction.run(WizardShortcutAction.java:95)

        at org.eclipse.jface.action.Action.runWithEvent(Action.java:499)

        at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)

        at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)

        at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)

        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1392)

        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3742)

        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3363)

        at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1113)

        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)

        at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:997)

        at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:140)

        at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:611)

        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)

        at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:567)

        at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)

        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:124)

        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)

        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)

        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)

        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

        at java.lang.reflect.Method.invoke(Method.java:606)

        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)

        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)

        at org.eclipse.equinox.launcher.Main.run(Main.java:1450)

        at org.eclipse.equinox.launcher.Main.main(Main.java:1426)

      Caused by: java.lang.ClassNotFoundException: org.sonatype.aether.version.InvalidVersionSpecificationException cannot be found by org.switchyard.tools.ui_1.1.5.v20140403-2328-H5-Final

        at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)

        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)

        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)

        at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)

        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

        ... 35 more

       

       

      Here is the error I get in my JBDS log when attempting to open an existing switchyard.xml file in one of my projects:

       

      !ENTRY org.eclipse.e4.ui.css.swt 4 0 2014-04-24 12:24:11.183

      !MESSAGE Failed to get bundle for: bundleclass://net.jeeeyul.eclipse.themes/net.jeeeyul.eclipse.themes.rendering.JeeeyulsTabRenderer

       

       

      !ENTRY org.eclipse.e4.ui.css.swt 4 0 2014-04-24 12:24:11.185

      !MESSAGE Failed to get bundle for: bundleclass://net.jeeeyul.eclipse.themes/net.jeeeyul.eclipse.themes.rendering.JeeeyulsTabRenderer

       

       

      !ENTRY org.eclipse.e4.ui.css.swt 4 0 2014-04-24 12:26:20.750

      !MESSAGE Failed to get bundle for: bundleclass://net.jeeeyul.eclipse.themes/net.jeeeyul.eclipse.themes.rendering.JeeeyulsTabRenderer

       

       

      !ENTRY org.eclipse.e4.ui.css.swt 4 0 2014-04-24 12:26:20.751

      !MESSAGE Failed to get bundle for: bundleclass://net.jeeeyul.eclipse.themes/net.jeeeyul.eclipse.themes.rendering.JeeeyulsTabRenderer

       

       

      !ENTRY org.eclipse.core.jobs 4 2 2014-04-24 12:26:26.692

      !MESSAGE An internal error occurred during: "Updating SwitchYard project meta-data.".

      !STACK 0

      java.lang.NoClassDefFoundError: org/sonatype/aether/artifact/Artifact

        at org.switchyard.tools.ui.common.impl.SwitchYardProject.getSwitchYardPlugin(SwitchYardProject.java:438)

        at org.switchyard.tools.ui.common.impl.SwitchYardProject.access$0(SwitchYardProject.java:434)

        at org.switchyard.tools.ui.common.impl.SwitchYardProject$SwitchYardConfigurePlugin.<init>(SwitchYardProject.java:536)

        at org.switchyard.tools.ui.common.impl.SwitchYardProject$SwitchYardConfigurePlugin.<init>(SwitchYardProject.java:535)

        at org.switchyard.tools.ui.common.impl.SwitchYardProject.init(SwitchYardProject.java:385)

        at org.switchyard.tools.ui.common.impl.SwitchYardProject.load(SwitchYardProject.java:274)

        at org.switchyard.tools.ui.common.impl.SwitchYardProjectManager$UpdateMetadataJob.run(SwitchYardProjectManager.java:224)

        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

      Caused by: java.lang.ClassNotFoundException: org.sonatype.aether.artifact.Artifact cannot be found by org.switchyard.tools.ui_1.1.5.v20140403-2328-H5-Final

        at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)

        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)

        at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)

        at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)

        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

        ... 8 more

       

       

      !ENTRY org.switchyard.tools.ui 4 0 2014-04-24 12:26:26.861

      !MESSAGE Error loading SwitchYard configuration for: P/pubsub

      !STACK 0

      java.lang.NullPointerException

        at org.switchyard.tools.ui.explorer.impl.SwitchYardRootNode.reload(SwitchYardRootNode.java:163)

        at org.switchyard.tools.ui.explorer.SwitchYardExplorerContentProvider$SwitchYardRefreshJob.run(SwitchYardExplorerContentProvider.java:200)

        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)

       

       

      Anyone have any idea why this might be happening?

       

      Thanks