2 Replies Latest reply on Apr 28, 2014 4:04 AM by Vladislav Rames

    Jboss EAP 6.2 (Jboss 7.1.1) - how/where can be set -XX:-UseGCOverheadLimit ?

    Vladislav Rames Newbie

      Hello,

       

      I try to solve "java.lang.OutOfMemoryError: GC overhead limit exceeded" error using "-XX:-UseGCOverheadLimit" option

      in JAVA_OPTS. I have this java version:

       

      [jboss@jboss-test jboss-as-7.1.1.Final]$ java -version

      java version "1.6.0_28"

      OpenJDK Runtime Environment (IcedTea6 1.13.0pre) (rhel-1.66.1.13.0.el6-i386)

      OpenJDK Client VM (build 23.25-b01, mixed mode)

       

      I've tried to add this option to JAVA_OPTS in domain.conf:

       

      ...

      #

      # Specify options to pass to the Java VM.

      #

      JAVA_OPTS="$JAVA_OPTS -XX:-UseGCOverheadLimit"

      ...

       

       

      Then I have restarted jboss, I can see this in logfile:

       

      =========================================================================

       

        JBoss Bootstrap Environment

       

        JBOSS_HOME: /opt/jboss/jboss-as-7.1.1.Final

       

        JAVA: java

       

        JAVA_OPTS: -Xms128m -Xmx256m -XX:MaxPermSize=64m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Djboss.domain.default.config=domain.xml -Djboss.host.default.config=host.xml -XX:-UseGCOverheadLimit

       

      =========================================================================

      But when I try to grep java processes, It hasn't had those option. Where I did a mistake, please?

      Thanks in advance.