4 Replies Latest reply on May 5, 2014 11:56 AM by Hector Mendoza

    Run JBoss 7.1 on Java 8

    Hector Mendoza Newbie

      We want to move forward with Java 8, so I download AS  7.1 and 7.0 but it get stuck when is starting up.

       

      I see this issue but is for EAP and is solved for wildfly 8 version.

       

      I use JBoss AS 7.1.1.Final and Jboss 7.1.0.Final both get stuck.

      Wildfly 8 Final and EAP 6.2 run without problems.

       

      I use windows 32 bit version.

      Java 1.8.0_05.

      Standalone get stuck, domain startup works.

       

      In the gettings started guide said:

      Java SE 6 or later (we recommend that you use the latest update available)

      Java SE 7 can be used with JBoss AS 7

       

      So, is not compatible with java 8 or have some issues with this config?

       

      JBossAs7.png