1 Reply Latest reply on May 3, 2014 1:26 PM by Luigi Banzato

    JBREM000200: Authentication failed: the server presented no authentication mechanisms

    Luigi Banzato Newbie

      Hi

       

      I am running wildfly-8.0.0.Final and have been successfully using the wildfly-maven-plugin to deploy my project to a local standalone wildfly instance.

       

      However, when I tried to configure the maven plugin to connect to a remote server (also standalone), it is not working.

       

      Here's the plugin configuration:

      <plugin>
        <groupId>org.wildfly.plugins</groupId>
        <artifactId>wildfly-maven-plugin</artifactId>
        <version>1.0.1.Final</version>
        <executions>
          <execution>
            <id>deploy-project</id>
            <phase>install</phase>
            <goals>
              <goal>deploy</goal>
            </goals>
            <configuration>
              <hostname>54.72.100.233</hostname>
              <port>9990</port>
              <username>user</username>
              <password>password</password>
            </configuration>
          </execution>
        </executions>
      </plugin>
      
      

       

       

      The Management Console is available at http://54.72.100.233:9990, but the maven build fails:

      [INFO] --- wildfly-maven-plugin:1.0.1.Final:deploy (deploy-project) @ project-
      webapp ---
      Mai 03, 2014 3:03:52 PM org.xnio.Xnio <clinit>
      INFO: XNIO version 3.2.0.Final
      Mai 03, 2014 3:03:52 PM org.xnio.nio.NioXnio <clinit>
      INFO: XNIO NIO Implementation Version 3.2.0.Final
      Mai 03, 2014 3:03:52 PM org.jboss.remoting3.EndpointImpl <clinit>
      INFO: JBoss Remoting version 4.0.0.Final
      Authenticating against security realm: ManagementRealm
      Mai 03, 2014 3:03:53 PM org.jboss.remoting3.remote.RemoteConnection handleExcept
      ion
      ERROR: JBREM000200: Remote connection failed: javax.security.sasl.SaslException:
      Authentication failed: the server presented no authentication mechanisms
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 8.404 s
      [INFO] Finished at: 2014-05-03T15:03:53+00:00
      [INFO] Final Memory: 28M/269M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.wildfly.plugins:wildfly-maven-plugin:1.0.1.Fi
      nal:deploy (deploy-project) on project project-webapp: Could not execute goal
      deploy on C:\svn\project\project-webapp\target\project-webapp.war. Reason: I/
      O Error could not execute operation '{
      [ERROR] "operation" => "read-attribute",
      [ERROR] "address" => [],
      [ERROR] "name" => "launch-type"
      [ERROR] }': java.net.ConnectException: JBAS012174: Could not connect to http-rem
      oting://54.72.100.233:9990. The connection failed: Authentication failed: the ser
      ver presented no authentication mechanisms
      
      

       

      And here's a link to my standalone.xml file:

      http://textuploader.com/r4zi

       

      I'm sure the user and password used in the pom.xml file exist in the Wildfly instance, in the ManagementRealm (I double checked in the mgmt-users.properties file, and it is there).

       

      In the past versions, the port was different (I had this working on JBoss AS7), but in the final release of WildFly they reduced the number of ports (WildFly 8 Final is released! · WildFly) and after that, I didn't manage to get it working again.

       

      I've done a lot of research on this, but most of the discussions I found are either of people having problems with local deployment or EJB remoting, not the maven plugin. I've tested all suggested solutions I found and none of them worked.

       

      If anyone has gone through this problem before, or has any pointers, I would be really grateful.