5 Replies Latest reply on May 13, 2014 1:07 PM by Justin Bertram

    Listening to a Remote Topic In JBoss EAP 6.1

    Sankalp Madaan Newbie

      I am trying to listen to a remote Topic But I am getting the following errors while deploying the application:

       

      service jboss.ra.hornetq-ra (missing) dependents: [service jboss.deployment.subunit."NORSAPP.ear"."NORSMDB.jar".component.NNAMDB.CREATE, service jboss.deployment.subunit."NORSAPP.ear"."NORSMDB.jar".component.NorsDeadLetterMDBListener.CREATE, service jboss.deployment.subunit."NORSAPP.ear"."NORSMDB.jar".component.NorsNCIMDBListener.CREATE]


      I am using the following configuration to listen to remote Topic :

       

      @MessageDriven(activationConfig = {
      
        @ActivationConfigProperty(propertyName = "destinationType", propertyValue = "javax.jms.Topic"),
        @ActivationConfigProperty(propertyName = "destination", propertyValue = "/topic/NORSTopic"),
        @ActivationConfigProperty(propertyName = "user", propertyValue = "user"),
        @ActivationConfigProperty(propertyName = "password", propertyValue = "password"),
        @ActivationConfigProperty(propertyName = "subscriptionDurability", propertyValue = "Durable"),  
        @ActivationConfigProperty(propertyName = "clientID", propertyValue = "Durable-Sub2"),
        @ActivationConfigProperty(propertyName = "connectorClassName", propertyValue = "org.hornetq.core.remoting.impl.netty.NettyConnectorFactory"),          
           @ActivationConfigProperty(propertyName = "connectionParameters", propertyValue = "host=10.36.144.157;port=5445"),
        @ActivationConfigProperty(propertyName = "subscriptionName",propertyValue = "client2"),
        @ActivationConfigProperty(propertyName = "messageSelector",propertyValue = "affiliate = 'NCI'"),
        @ActivationConfigProperty(propertyName = "shareSubscriptions", propertyValue="true")
      
        })
      

       

      Can you please tell what I am missing?

        • 1. Re: Listening to a Remote Topic In JBoss EAP 6.1
          Justin Bertram Master

          Can you paste/attach your server configuration?

          • 2. Re: Re: Listening to a Remote Topic In JBoss EAP 6.1
            Sankalp Madaan Newbie
            <?xml version='1.0' encoding='UTF-8'?>
            
            
            <server xmlns="urn:jboss:domain:1.4">
                <extensions>
                    <extension module="org.jboss.as.clustering.infinispan"/>
                    <extension module="org.jboss.as.clustering.jgroups"/>
                    <extension module="org.jboss.as.cmp"/>
                    <extension module="org.jboss.as.connector"/>
                    <extension module="org.jboss.as.deployment-scanner"/>
                    <extension module="org.jboss.as.ee"/>
                    <extension module="org.jboss.as.ejb3"/>
                    <extension module="org.jboss.as.jacorb"/>
                    <extension module="org.jboss.as.jaxr"/>
                    <extension module="org.jboss.as.jaxrs"/>
                    <extension module="org.jboss.as.jdr"/>
                    <extension module="org.jboss.as.jmx"/>
                    <extension module="org.jboss.as.jpa"/>
                    <extension module="org.jboss.as.jsf"/>
                    <extension module="org.jboss.as.jsr77"/>
                    <extension module="org.jboss.as.logging"/>
                    <extension module="org.jboss.as.mail"/>
                    <extension module="org.jboss.as.messaging"/>
                    <extension module="org.jboss.as.modcluster"/>
                    <extension module="org.jboss.as.naming"/>
                    <extension module="org.jboss.as.pojo"/>
                    <extension module="org.jboss.as.remoting"/>
                    <extension module="org.jboss.as.sar"/>
                    <extension module="org.jboss.as.security"/>
                    <extension module="org.jboss.as.threads"/>
                    <extension module="org.jboss.as.transactions"/>
                    <extension module="org.jboss.as.web"/>
                    <extension module="org.jboss.as.webservices"/>
                    <extension module="org.jboss.as.weld"/>
                </extensions>
                <management>
                    <security-realms>
                        <security-realm name="ManagementRealm">
                            <authentication>
                                <local default-user="$local"/>
                                <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
                            </authentication>
                        </security-realm>
                        <security-realm name="ApplicationRealm">
                         <server-identities>
                                  <secret value="Tk9SU1Bhc3N3b3JkMTIzJA==" />
                           </server-identities>
              <authentication>
                                <local default-user="$local" allowed-users="*"/>
                                <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
                            </authentication>
                            <authorization>
                                <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>
                            </authorization>
                        </security-realm>
                    </security-realms>
                    <management-interfaces>
                        <native-interface security-realm="ManagementRealm">
                            <socket-binding native="management-native"/>
                        </native-interface>
                        <http-interface security-realm="ManagementRealm">
                            <socket-binding http="management-http"/>
                        </http-interface>
                    </management-interfaces>
                </management>
                <profile>
                    <subsystem xmlns="urn:jboss:domain:logging:1.2">
                        <periodic-rotating-file-handler name="FILE" autoflush="true">
                            <formatter>
                                <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
                            </formatter>
                            <file relative-to="jboss.server.log.dir" path="server.log"/>
                            <suffix value=".yyyy-MM-dd"/>
                            <append value="true"/>
                        </periodic-rotating-file-handler>
                        <logger category="com.arjuna">
                            <level name="WARN"/>
                        </logger>
                        <logger category="org.apache.tomcat.util.modeler">
                            <level name="WARN"/>
                        </logger>
                        <logger category="org.jboss.as.config">
                            <level name="DEBUG"/>
                        </logger>
                        <logger category="sun.rmi">
                            <level name="WARN"/>
                        </logger>
                        <logger category="jacorb">
                            <level name="WARN"/>
                        </logger>
                        <logger category="jacorb.config">
                            <level name="ERROR"/>
                        </logger>
                        <root-logger>
                            <level name="INFO"/>
                            <handlers>
                                <handler name="FILE"/>
                            </handlers>
                        </root-logger>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:cmp:1.1"/>
                    <subsystem xmlns="urn:jboss:domain:datasources:1.1">
                        <datasources>
                            <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="ExampleDS" enabled="true" use-java-context="true">
                                <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1</connection-url>
                                <driver>h2</driver>
                                <security>
                                    <user-name>sa</user-name>
                                    <password>sa</password>
                                </security>
                            </datasource>
                            <drivers>
                                <driver name="h2" module="com.h2database.h2">
                                    <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class>
                                </driver>
                            </drivers>
                        </datasources>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">
                        <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="0"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:ee:1.1">
                        <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>
                        <jboss-descriptor-property-replacement>true</jboss-descriptor-property-replacement>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:ejb3:1.4">
                        <session-bean>
                            <stateless>
                                <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>
                            </stateless>
                            <stateful default-access-timeout="5000" cache-ref="simple" clustered-cache-ref="clustered"/>
                            <singleton default-access-timeout="5000"/>
                        </session-bean>
                        <mdb>
                            <resource-adapter-ref resource-adapter-name="hornetq-ra"/>
                            <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>
                        </mdb>
                        <pools>
                            <bean-instance-pools>
                                <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                                <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                            </bean-instance-pools>
                        </pools>
                        <caches>
                            <cache name="simple" aliases="NoPassivationCache"/>
                            <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>
                            <cache name="clustered" passivation-store-ref="infinispan" aliases="StatefulTreeCache"/>
                        </caches>
                        <passivation-stores>
                            <file-passivation-store name="file"/>
                            <cluster-passivation-store name="infinispan" cache-container="ejb"/>
                        </passivation-stores>
                        <async thread-pool-name="default"/>
                        <timer-service thread-pool-name="default">
                            <data-store path="timer-service-data" relative-to="jboss.server.data.dir"/>
                        </timer-service>
                        <remote connector-ref="remoting-connector" thread-pool-name="default"/>
                        <thread-pools>
                            <thread-pool name="default">
                                <max-threads count="10"/>
                                <keepalive-time time="100" unit="milliseconds"/>
                            </thread-pool>
                        </thread-pools>
                        <iiop enable-by-default="false" use-qualified-name="false"/>
                        <default-security-domain value="other"/>
                        <default-missing-method-permissions-deny-access value="true"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:infinispan:1.4">
                        <cache-container name="singleton" aliases="cluster ha-partition" default-cache="default">
                            <transport lock-timeout="60000"/>
                            <replicated-cache name="default" mode="SYNC" batching="true">
                                <locking isolation="REPEATABLE_READ"/>
                            </replicated-cache>
                        </cache-container>
                        <cache-container name="web" aliases="standard-session-cache" default-cache="repl" module="org.jboss.as.clustering.web.infinispan">
                            <transport lock-timeout="60000"/>
                            <replicated-cache name="repl" mode="ASYNC" batching="true">
                                <file-store/>
                            </replicated-cache>
                            <replicated-cache name="sso" mode="SYNC" batching="true"/>
                            <distributed-cache name="dist" mode="ASYNC" batching="true" l1-lifespan="0">
                                <file-store/>
                            </distributed-cache>
                        </cache-container>
                        <cache-container name="ejb" aliases="sfsb sfsb-cache" default-cache="repl" module="org.jboss.as.clustering.ejb3.infinispan">
                            <transport lock-timeout="60000"/>
                            <replicated-cache name="repl" mode="ASYNC" batching="true">
                                <eviction strategy="LRU" max-entries="10000"/>
                                <file-store/>
                            </replicated-cache>
                            <!--
                              ~  Clustered cache used internally by EJB subsytem for managing the client-mapping(s) of
                              ~                 the socketbinding referenced by the EJB remoting connector 
                              -->
                            <replicated-cache name="remote-connector-client-mappings" mode="SYNC" batching="true"/>
                            <distributed-cache name="dist" mode="ASYNC" batching="true" l1-lifespan="0">
                                <eviction strategy="LRU" max-entries="10000"/>
                                <file-store/>
                            </distributed-cache>
                        </cache-container>
                        <cache-container name="hibernate" default-cache="local-query" module="org.jboss.as.jpa.hibernate:4">
                            <transport lock-timeout="60000"/>
                            <local-cache name="local-query">
                                <transaction mode="NONE"/>
                                <eviction strategy="LRU" max-entries="10000"/>
                                <expiration max-idle="100000"/>
                            </local-cache>
                            <invalidation-cache name="entity" mode="SYNC">
                                <transaction mode="NON_XA"/>
                                <eviction strategy="LRU" max-entries="10000"/>
                                <expiration max-idle="100000"/>
                            </invalidation-cache>
                            <replicated-cache name="timestamps" mode="ASYNC">
                                <transaction mode="NONE"/>
                                <eviction strategy="NONE"/>
                            </replicated-cache>
                        </cache-container>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jacorb:1.3">
                        <orb socket-binding="jacorb" ssl-socket-binding="jacorb-ssl">
                            <initializers transactions="spec" security="identity"/>
                        </orb>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jaxr:1.1">
                        <connection-factory jndi-name="java:jboss/jaxr/ConnectionFactory"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:jca:1.1">
                        <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>
                        <bean-validation enabled="true"/>
                        <default-workmanager>
                            <short-running-threads>
                                <core-threads count="50"/>
                                <queue-length count="50"/>
                                <max-threads count="50"/>
                                <keepalive-time time="10" unit="seconds"/>
                            </short-running-threads>
                            <long-running-threads>
                                <core-threads count="50"/>
                                <queue-length count="50"/>
                                <max-threads count="50"/>
                                <keepalive-time time="10" unit="seconds"/>
                            </long-running-threads>
                        </default-workmanager>
                        <cached-connection-manager/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:jgroups:1.1" default-stack="udp">
                        <stack name="udp">
                            <transport type="UDP" socket-binding="jgroups-udp"/>
                            <protocol type="PING"/>
                            <protocol type="MERGE3"/>
                            <protocol type="FD_SOCK" socket-binding="jgroups-udp-fd"/>
                            <protocol type="FD"/>
                            <protocol type="VERIFY_SUSPECT"/>
                            <protocol type="pbcast.NAKACK"/>
                            <protocol type="UNICAST2"/>
                            <protocol type="pbcast.STABLE"/>
                            <protocol type="pbcast.GMS"/>
                            <protocol type="UFC"/>
                            <protocol type="MFC"/>
                            <protocol type="FRAG2"/>
                            <protocol type="RSVP"/>
                        </stack>
                        <stack name="tcp">
                            <transport type="TCP" socket-binding="jgroups-tcp"/>
                            <protocol type="MPING" socket-binding="jgroups-mping"/>
                            <protocol type="MERGE2"/>
                            <protocol type="FD_SOCK" socket-binding="jgroups-tcp-fd"/>
                            <protocol type="FD"/>
                            <protocol type="VERIFY_SUSPECT"/>
                            <protocol type="pbcast.NAKACK"/>
                            <protocol type="UNICAST2"/>
                            <protocol type="pbcast.STABLE"/>
                            <protocol type="pbcast.GMS"/>
                            <protocol type="UFC"/>
                            <protocol type="MFC"/>
                            <protocol type="FRAG2"/>
                            <protocol type="RSVP"/>
                        </stack>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jmx:1.2">
                        <expose-resolved-model/>
                        <expose-expression-model/>
                        <remoting-connector/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jpa:1.1">
                        <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jsf:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:jsr77:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:mail:1.1">
                        <mail-session jndi-name="java:jboss/mail/Default">
                            <smtp-server outbound-socket-binding-ref="mail-smtp"/>
                        </mail-session>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:messaging:1.3">
                        <hornetq-server>
                            <cluster-password>${jboss.messaging.cluster.password:CHANGE ME!!}</cluster-password>
                            <persistence-enabled>true</persistence-enabled>
                            <journal-type>NIO</journal-type>
                            <journal-min-files>2</journal-min-files>
                            <connectors>
                                <netty-connector name="netty" socket-binding="messaging"/>
                                <netty-connector name="netty-throughput" socket-binding="messaging-throughput">
                                    <param key="batch-delay" value="50"/>
                                </netty-connector>
                                <in-vm-connector name="in-vm" server-id="0"/>
                            </connectors>
                            <acceptors>
                                <netty-acceptor name="netty" socket-binding="messaging"/>
                                <netty-acceptor name="netty-throughput" socket-binding="messaging-throughput">
                                    <param key="batch-delay" value="50"/>
                                    <param key="direct-deliver" value="false"/>
                                </netty-acceptor>
                                <in-vm-acceptor name="in-vm" server-id="0"/>
                            </acceptors>
                            <broadcast-groups>
                                <broadcast-group name="bg-group1">
                                    <socket-binding>messaging-group</socket-binding>
                                    <broadcast-period>5000</broadcast-period>
                                    <connector-ref>netty</connector-ref>
                                </broadcast-group>
                            </broadcast-groups>
                            <discovery-groups>
                                <discovery-group name="dg-group1">
                                    <socket-binding>messaging-group</socket-binding>
                                    <refresh-timeout>10000</refresh-timeout>
                                </discovery-group>
                            </discovery-groups>
                            <cluster-connections>
                                <cluster-connection name="my-cluster">
                                    <address>jms</address>
                                    <connector-ref>netty</connector-ref>
                                    <discovery-group-ref discovery-group-name="dg-group1"/>
                                </cluster-connection>
                            </cluster-connections>
                            <security-settings>
                                <security-setting match="#">
                                    <permission type="send" roles="guest"/>
                                    <permission type="consume" roles="guest"/>
                                    <permission type="createNonDurableQueue" roles="guest"/>
                                    <permission type="deleteNonDurableQueue" roles="guest"/>
                                    <permission type="createDurableQueue" roles="guest"/>
                                    <permission type="deleteDurableQueue" roles="guest"/>   
                                </security-setting>
                            </security-settings>
                            <address-settings>
                                <!--default for catch all-->
                                <address-setting match="#">
                                    <dead-letter-address>jms.queue.NORSDLQ</dead-letter-address>
                                    <expiry-address>jms.queue.ExpiryQueue</expiry-address>
                                    <redelivery-delay>0</redelivery-delay>
                                    <redistribution-delay>1000</redistribution-delay>
                                    <max-size-bytes>10485760</max-size-bytes>
                                    <address-full-policy>BLOCK</address-full-policy>
              <max-delivery-attempts>5</max-delivery-attempts>
                                    <message-counter-history-day-limit>10</message-counter-history-day-limit>
                                </address-setting>
                            </address-settings>
                            <jms-connection-factories>
                                <connection-factory name="InVmConnectionFactory">
                                    <connectors>
                                        <connector-ref connector-name="in-vm"/>
                                    </connectors>
                                    <entries>
                                        <entry name="java:/ConnectionFactory"/>
                                    </entries>
                                </connection-factory>
                                <connection-factory name="RemoteConnectionFactory">
                                    <connectors>
                                        <connector-ref connector-name="netty"/>
                                    </connectors>
                                    <entries>
                                        <entry name="java:jboss/exported/jms/RemoteConnectionFactory"/>
                                    </entries>
                                    <ha>true</ha>
                                    <block-on-acknowledge>true</block-on-acknowledge>
                                    <retry-interval>1000</retry-interval>
                                    <retry-interval-multiplier>1.0</retry-interval-multiplier>
                                    <reconnect-attempts>-1</reconnect-attempts>
                                </connection-factory>
                                <pooled-connection-factory name="hornetq-ra">
                                    <transaction mode="xa"/>
                                    <connectors>
                                        <connector-ref connector-name="in-vm"/>
                                    </connectors>
                                    <entries>
                                        <entry name="java:/JmsXA"/>
                                    </entries>
                                </pooled-connection-factory>
                            </jms-connection-factories>
                           <jms-destinations>
              <jms-topic name="NORSTopic">
                                    <entry name="topic/NORSTopic"/>
                                    <entry name="java:jboss/exported/jms/topic/NORSTopic"/>
                            </jms-topic>
              <jms-queue name="NORSDLQ">
                            <entry name="queue/NORSDLQ"/>
                             <entry name="java:jboss/exported/jms/queue/NORSDLQ"/>
              </jms-queue>
                           </jms-destinations>
                        </hornetq-server>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:modcluster:1.1">
                        <mod-cluster-config advertise-socket="modcluster" proxy-list="${jboss.modcluster.proxyList}" balancer="${jboss.modcluster.balancer}" connector="ajp">
                            <dynamic-load-provider>
                                <load-metric type="busyness"/>
                            </dynamic-load-provider>
                        </mod-cluster-config>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:naming:1.3">
                        <remote-naming/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:remoting:1.1">
                        <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:resource-adapters:1.1"/>
                    <subsystem xmlns="urn:jboss:domain:sar:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:security:1.2">
                        <security-domains>
                            <security-domain name="other" cache-type="default">
                                <authentication>
                                    <login-module code="Remoting" flag="optional">
                                        <module-option name="password-stacking" value="useFirstPass"/>
                                    </login-module>
                                    <login-module code="RealmDirect" flag="required">
                                        <module-option name="password-stacking" value="useFirstPass"/>
                                    </login-module>
                                </authentication>
                            </security-domain>
                            <security-domain name="jboss-web-policy" cache-type="default">
                                <authorization>
                                    <policy-module code="Delegating" flag="required"/>
                                </authorization>
                            </security-domain>
                            <security-domain name="jboss-ejb-policy" cache-type="default">
                                <authorization>
                                    <policy-module code="Delegating" flag="required"/>
                                </authorization>
                            </security-domain>
                        </security-domains>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:threads:1.1"/>
                    <subsystem xmlns="urn:jboss:domain:transactions:1.3">
                        <core-environment>
                            <process-id>
                                <uuid/>
                            </process-id>
                        </core-environment>
                        <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>
                        <coordinator-environment default-timeout="300"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:web:1.4" default-virtual-server="default-host" native="false">
                        <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
                        <connector name="ajp" protocol="AJP/1.3" scheme="http" socket-binding="ajp"/>
                        <virtual-server name="default-host" enable-welcome-root="true">
                            <alias name="localhost"/>
                            <alias name="example.com"/>
                        </virtual-server>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:webservices:1.2">
                        <modify-wsdl-address>true</modify-wsdl-address>
                        <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>
                        <endpoint-config name="Standard-Endpoint-Config"/>
                        <endpoint-config name="Recording-Endpoint-Config">
                            <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">
                                <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>
                            </pre-handler-chain>
                        </endpoint-config>
                        <client-config name="Standard-Client-Config"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:weld:1.0"/>
                </profile>
                <interfaces>
                    <interface name="management">
                        <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>
                    </interface>
                    <interface name="public">
                        <inet-address value="${jboss.bind.address:127.0.0.1}"/>
                    </interface>
                    <!-- TODO - only show this if the jacorb subsystem is added  -->
                    <interface name="unsecure">
                        <!--
                          ~  Used for IIOP sockets in the standard configuration.
                          ~                  To secure JacORB you need to setup SSL 
                          -->
                        <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>
                    </interface>
                </interfaces>
                <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
                    <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>
                    <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
                    <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>
                    <socket-binding name="ajp" port="8009"/>
                    <socket-binding name="http" port="8080"/>
                    <socket-binding name="https" port="8443"/>
                    <socket-binding name="jacorb" interface="unsecure" port="3528"/>
                    <socket-binding name="jacorb-ssl" interface="unsecure" port="3529"/>
                    <socket-binding name="jgroups-mping" port="0" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45700"/>
                    <socket-binding name="jgroups-tcp" port="7600"/>
                    <socket-binding name="jgroups-tcp-fd" port="57600"/>
                    <socket-binding name="jgroups-udp" port="55200" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45688"/>
                    <socket-binding name="jgroups-udp-fd" port="54200"/>
                    <socket-binding name="messaging" port="5445"/>
                    <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:231.7.7.7}" multicast-port="${jboss.messaging.group.port:9876}"/>
                    <socket-binding name="messaging-throughput" port="5455"/>
                    <socket-binding name="modcluster" port="0" multicast-address="224.0.1.105" multicast-port="23364"/>
                    <socket-binding name="remoting" port="4447"/>
                    <socket-binding name="txn-recovery-environment" port="4712"/>
                    <socket-binding name="txn-status-manager" port="4713"/>
                    <outbound-socket-binding name="mail-smtp">
                        <remote-destination host="localhost" port="25"/>
                    </outbound-socket-binding>
                </socket-binding-group>
            </server>
            
            <?xml version='1.0' encoding='UTF-8'?>
            
            
            <server xmlns="urn:jboss:domain:1.4">
                <extensions>
                    <extension module="org.jboss.as.clustering.infinispan"/>
                    <extension module="org.jboss.as.clustering.jgroups"/>
                    <extension module="org.jboss.as.cmp"/>
                    <extension module="org.jboss.as.connector"/>
                    <extension module="org.jboss.as.deployment-scanner"/>
                    <extension module="org.jboss.as.ee"/>
                    <extension module="org.jboss.as.ejb3"/>
                    <extension module="org.jboss.as.jacorb"/>
                    <extension module="org.jboss.as.jaxr"/>
                    <extension module="org.jboss.as.jaxrs"/>
                    <extension module="org.jboss.as.jdr"/>
                    <extension module="org.jboss.as.jmx"/>
                    <extension module="org.jboss.as.jpa"/>
                    <extension module="org.jboss.as.jsf"/>
                    <extension module="org.jboss.as.jsr77"/>
                    <extension module="org.jboss.as.logging"/>
                    <extension module="org.jboss.as.mail"/>
                    <extension module="org.jboss.as.messaging"/>
                    <extension module="org.jboss.as.modcluster"/>
                    <extension module="org.jboss.as.naming"/>
                    <extension module="org.jboss.as.pojo"/>
                    <extension module="org.jboss.as.remoting"/>
                    <extension module="org.jboss.as.sar"/>
                    <extension module="org.jboss.as.security"/>
                    <extension module="org.jboss.as.threads"/>
                    <extension module="org.jboss.as.transactions"/>
                    <extension module="org.jboss.as.web"/>
                    <extension module="org.jboss.as.webservices"/>
                    <extension module="org.jboss.as.weld"/>
                </extensions>
                <management>
                    <security-realms>
                        <security-realm name="ManagementRealm">
                            <authentication>
                                <local default-user="$local"/>
                                <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
                            </authentication>
                        </security-realm>
                        <security-realm name="ApplicationRealm">
                         <server-identities>
                                  <secret value="Tk9SU1Bhc3N3b3JkMTIzJA==" />
                           </server-identities>
              <authentication>
                                <local default-user="$local" allowed-users="*"/>
                                <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
                            </authentication>
                            <authorization>
                                <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>
                            </authorization>
                        </security-realm>
                    </security-realms>
                    <management-interfaces>
                        <native-interface security-realm="ManagementRealm">
                            <socket-binding native="management-native"/>
                        </native-interface>
                        <http-interface security-realm="ManagementRealm">
                            <socket-binding http="management-http"/>
                        </http-interface>
                    </management-interfaces>
                </management>
                <profile>
                    <subsystem xmlns="urn:jboss:domain:logging:1.2">
                        <periodic-rotating-file-handler name="FILE" autoflush="true">
                            <formatter>
                                <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
                            </formatter>
                            <file relative-to="jboss.server.log.dir" path="server.log"/>
                            <suffix value=".yyyy-MM-dd"/>
                            <append value="true"/>
                        </periodic-rotating-file-handler>
                        <logger category="com.arjuna">
                            <level name="WARN"/>
                        </logger>
                        <logger category="org.apache.tomcat.util.modeler">
                            <level name="WARN"/>
                        </logger>
                        <logger category="org.jboss.as.config">
                            <level name="DEBUG"/>
                        </logger>
                        <logger category="sun.rmi">
                            <level name="WARN"/>
                        </logger>
                        <logger category="jacorb">
                            <level name="WARN"/>
                        </logger>
                        <logger category="jacorb.config">
                            <level name="ERROR"/>
                        </logger>
                        <root-logger>
                            <level name="INFO"/>
                            <handlers>
                                <handler name="FILE"/>
                            </handlers>
                        </root-logger>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:cmp:1.1"/>
                    <subsystem xmlns="urn:jboss:domain:datasources:1.1">
                        <datasources>
                            <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="ExampleDS" enabled="true" use-java-context="true">
                                <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1</connection-url>
                                <driver>h2</driver>
                                <security>
                                    <user-name>sa</user-name>
                                    <password>sa</password>
                                </security>
                            </datasource>
                            <drivers>
                                <driver name="h2" module="com.h2database.h2">
                                    <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class>
                                </driver>
                            </drivers>
                        </datasources>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">
                        <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="0"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:ee:1.1">
                        <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>
                        <jboss-descriptor-property-replacement>true</jboss-descriptor-property-replacement>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:ejb3:1.4">
                        <session-bean>
                            <stateless>
                                <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>
                            </stateless>
                            <stateful default-access-timeout="5000" cache-ref="simple" clustered-cache-ref="clustered"/>
                            <singleton default-access-timeout="5000"/>
                        </session-bean>
                        <mdb>
                            <resource-adapter-ref resource-adapter-name="hornetq-ra"/>
                            <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>
                        </mdb>
                        <pools>
                            <bean-instance-pools>
                                <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                                <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                            </bean-instance-pools>
                        </pools>
                        <caches>
                            <cache name="simple" aliases="NoPassivationCache"/>
                            <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>
                            <cache name="clustered" passivation-store-ref="infinispan" aliases="StatefulTreeCache"/>
                        </caches>
                        <passivation-stores>
                            <file-passivation-store name="file"/>
                            <cluster-passivation-store name="infinispan" cache-container="ejb"/>
                        </passivation-stores>
                        <async thread-pool-name="default"/>
                        <timer-service thread-pool-name="default">
                            <data-store path="timer-service-data" relative-to="jboss.server.data.dir"/>
                        </timer-service>
                        <remote connector-ref="remoting-connector" thread-pool-name="default"/>
                        <thread-pools>
                            <thread-pool name="default">
                                <max-threads count="10"/>
                                <keepalive-time time="100" unit="milliseconds"/>
                            </thread-pool>
                        </thread-pools>
                        <iiop enable-by-default="false" use-qualified-name="false"/>
                        <default-security-domain value="other"/>
                        <default-missing-method-permissions-deny-access value="true"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:infinispan:1.4">
                        <cache-container name="singleton" aliases="cluster ha-partition" default-cache="default">
                            <transport lock-timeout="60000"/>
                            <replicated-cache name="default" mode="SYNC" batching="true">
                                <locking isolation="REPEATABLE_READ"/>
                            </replicated-cache>
                        </cache-container>
                        <cache-container name="web" aliases="standard-session-cache" default-cache="repl" module="org.jboss.as.clustering.web.infinispan">
                            <transport lock-timeout="60000"/>
                            <replicated-cache name="repl" mode="ASYNC" batching="true">
                                <file-store/>
                            </replicated-cache>
                            <replicated-cache name="sso" mode="SYNC" batching="true"/>
                            <distributed-cache name="dist" mode="ASYNC" batching="true" l1-lifespan="0">
                                <file-store/>
                            </distributed-cache>
                        </cache-container>
                        <cache-container name="ejb" aliases="sfsb sfsb-cache" default-cache="repl" module="org.jboss.as.clustering.ejb3.infinispan">
                            <transport lock-timeout="60000"/>
                            <replicated-cache name="repl" mode="ASYNC" batching="true">
                                <eviction strategy="LRU" max-entries="10000"/>
                                <file-store/>
                            </replicated-cache>
                            <!--
                              ~  Clustered cache used internally by EJB subsytem for managing the client-mapping(s) of
                              ~                 the socketbinding referenced by the EJB remoting connector 
                              -->
                            <replicated-cache name="remote-connector-client-mappings" mode="SYNC" batching="true"/>
                            <distributed-cache name="dist" mode="ASYNC" batching="true" l1-lifespan="0">
                                <eviction strategy="LRU" max-entries="10000"/>
                                <file-store/>
                            </distributed-cache>
                        </cache-container>
                        <cache-container name="hibernate" default-cache="local-query" module="org.jboss.as.jpa.hibernate:4">
                            <transport lock-timeout="60000"/>
                            <local-cache name="local-query">
                                <transaction mode="NONE"/>
                                <eviction strategy="LRU" max-entries="10000"/>
                                <expiration max-idle="100000"/>
                            </local-cache>
                            <invalidation-cache name="entity" mode="SYNC">
                                <transaction mode="NON_XA"/>
                                <eviction strategy="LRU" max-entries="10000"/>
                                <expiration max-idle="100000"/>
                            </invalidation-cache>
                            <replicated-cache name="timestamps" mode="ASYNC">
                                <transaction mode="NONE"/>
                                <eviction strategy="NONE"/>
                            </replicated-cache>
                        </cache-container>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jacorb:1.3">
                        <orb socket-binding="jacorb" ssl-socket-binding="jacorb-ssl">
                            <initializers transactions="spec" security="identity"/>
                        </orb>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jaxr:1.1">
                        <connection-factory jndi-name="java:jboss/jaxr/ConnectionFactory"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:jca:1.1">
                        <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>
                        <bean-validation enabled="true"/>
                        <default-workmanager>
                            <short-running-threads>
                                <core-threads count="50"/>
                                <queue-length count="50"/>
                                <max-threads count="50"/>
                                <keepalive-time time="10" unit="seconds"/>
                            </short-running-threads>
                            <long-running-threads>
                                <core-threads count="50"/>
                                <queue-length count="50"/>
                                <max-threads count="50"/>
                                <keepalive-time time="10" unit="seconds"/>
                            </long-running-threads>
                        </default-workmanager>
                        <cached-connection-manager/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:jgroups:1.1" default-stack="udp">
                        <stack name="udp">
                            <transport type="UDP" socket-binding="jgroups-udp"/>
                            <protocol type="PING"/>
                            <protocol type="MERGE3"/>
                            <protocol type="FD_SOCK" socket-binding="jgroups-udp-fd"/>
                            <protocol type="FD"/>
                            <protocol type="VERIFY_SUSPECT"/>
                            <protocol type="pbcast.NAKACK"/>
                            <protocol type="UNICAST2"/>
                            <protocol type="pbcast.STABLE"/>
                            <protocol type="pbcast.GMS"/>
                            <protocol type="UFC"/>
                            <protocol type="MFC"/>
                            <protocol type="FRAG2"/>
                            <protocol type="RSVP"/>
                        </stack>
                        <stack name="tcp">
                            <transport type="TCP" socket-binding="jgroups-tcp"/>
                            <protocol type="MPING" socket-binding="jgroups-mping"/>
                            <protocol type="MERGE2"/>
                            <protocol type="FD_SOCK" socket-binding="jgroups-tcp-fd"/>
                            <protocol type="FD"/>
                            <protocol type="VERIFY_SUSPECT"/>
                            <protocol type="pbcast.NAKACK"/>
                            <protocol type="UNICAST2"/>
                            <protocol type="pbcast.STABLE"/>
                            <protocol type="pbcast.GMS"/>
                            <protocol type="UFC"/>
                            <protocol type="MFC"/>
                            <protocol type="FRAG2"/>
                            <protocol type="RSVP"/>
                        </stack>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jmx:1.2">
                        <expose-resolved-model/>
                        <expose-expression-model/>
                        <remoting-connector/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jpa:1.1">
                        <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:jsf:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:jsr77:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:mail:1.1">
                        <mail-session jndi-name="java:jboss/mail/Default">
                            <smtp-server outbound-socket-binding-ref="mail-smtp"/>
                        </mail-session>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:messaging:1.3">
                        <hornetq-server>
                            <cluster-password>${jboss.messaging.cluster.password:CHANGE ME!!}</cluster-password>
                            <persistence-enabled>true</persistence-enabled>
                            <journal-type>NIO</journal-type>
                            <journal-min-files>2</journal-min-files>
                            <connectors>
                                <netty-connector name="netty" socket-binding="messaging"/>
                                <netty-connector name="netty-throughput" socket-binding="messaging-throughput">
                                    <param key="batch-delay" value="50"/>
                                </netty-connector>
                                <in-vm-connector name="in-vm" server-id="0"/>
                            </connectors>
                            <acceptors>
                                <netty-acceptor name="netty" socket-binding="messaging"/>
                                <netty-acceptor name="netty-throughput" socket-binding="messaging-throughput">
                                    <param key="batch-delay" value="50"/>
                                    <param key="direct-deliver" value="false"/>
                                </netty-acceptor>
                                <in-vm-acceptor name="in-vm" server-id="0"/>
                            </acceptors>
                            <broadcast-groups>
                                <broadcast-group name="bg-group1">
                                    <socket-binding>messaging-group</socket-binding>
                                    <broadcast-period>5000</broadcast-period>
                                    <connector-ref>netty</connector-ref>
                                </broadcast-group>
                            </broadcast-groups>
                            <discovery-groups>
                                <discovery-group name="dg-group1">
                                    <socket-binding>messaging-group</socket-binding>
                                    <refresh-timeout>10000</refresh-timeout>
                                </discovery-group>
                            </discovery-groups>
                            <cluster-connections>
                                <cluster-connection name="my-cluster">
                                    <address>jms</address>
                                    <connector-ref>netty</connector-ref>
                                    <discovery-group-ref discovery-group-name="dg-group1"/>
                                </cluster-connection>
                            </cluster-connections>
                            <security-settings>
                                <security-setting match="#">
                                    <permission type="send" roles="guest"/>
                                    <permission type="consume" roles="guest"/>
                                    <permission type="createNonDurableQueue" roles="guest"/>
                                    <permission type="deleteNonDurableQueue" roles="guest"/>
                                    <permission type="createDurableQueue" roles="guest"/>
                                    <permission type="deleteDurableQueue" roles="guest"/>   
                                </security-setting>
                            </security-settings>
                            <address-settings>
                                <!--default for catch all-->
                                <address-setting match="#">
                                    <dead-letter-address>jms.queue.NORSDLQ</dead-letter-address>
                                    <expiry-address>jms.queue.ExpiryQueue</expiry-address>
                                    <redelivery-delay>0</redelivery-delay>
                                    <redistribution-delay>1000</redistribution-delay>
                                    <max-size-bytes>10485760</max-size-bytes>
                                    <address-full-policy>BLOCK</address-full-policy>
              <max-delivery-attempts>5</max-delivery-attempts>
                                    <message-counter-history-day-limit>10</message-counter-history-day-limit>
                                </address-setting>
                            </address-settings>
                            <jms-connection-factories>
                                <connection-factory name="InVmConnectionFactory">
                                    <connectors>
                                        <connector-ref connector-name="in-vm"/>
                                    </connectors>
                                    <entries>
                                        <entry name="java:/ConnectionFactory"/>
                                    </entries>
                                </connection-factory>
                                <connection-factory name="RemoteConnectionFactory">
                                    <connectors>
                                        <connector-ref connector-name="netty"/>
                                    </connectors>
                                    <entries>
                                        <entry name="java:jboss/exported/jms/RemoteConnectionFactory"/>
                                    </entries>
                                    <ha>true</ha>
                                    <block-on-acknowledge>true</block-on-acknowledge>
                                    <retry-interval>1000</retry-interval>
                                    <retry-interval-multiplier>1.0</retry-interval-multiplier>
                                    <reconnect-attempts>-1</reconnect-attempts>
                                </connection-factory>
                                <pooled-connection-factory name="hornetq-ra">
                                    <transaction mode="xa"/>
                                    <connectors>
                                        <connector-ref connector-name="in-vm"/>
                                    </connectors>
                                    <entries>
                                        <entry name="java:/JmsXA"/>
                                    </entries>
                                </pooled-connection-factory>
                            </jms-connection-factories>
                           <jms-destinations>
              <jms-topic name="NORSTopic">
                                    <entry name="topic/NORSTopic"/>
                                    <entry name="java:jboss/exported/jms/topic/NORSTopic"/>
                            </jms-topic>
              <jms-queue name="NORSDLQ">
                            <entry name="queue/NORSDLQ"/>
                             <entry name="java:jboss/exported/jms/queue/NORSDLQ"/>
              </jms-queue>
                           </jms-destinations>
                        </hornetq-server>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:modcluster:1.1">
                        <mod-cluster-config advertise-socket="modcluster" proxy-list="${jboss.modcluster.proxyList}" balancer="${jboss.modcluster.balancer}" connector="ajp">
                            <dynamic-load-provider>
                                <load-metric type="busyness"/>
                            </dynamic-load-provider>
                        </mod-cluster-config>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:naming:1.3">
                        <remote-naming/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:remoting:1.1">
                        <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:resource-adapters:1.1"/>
                    <subsystem xmlns="urn:jboss:domain:sar:1.0"/>
                    <subsystem xmlns="urn:jboss:domain:security:1.2">
                        <security-domains>
                            <security-domain name="other" cache-type="default">
                                <authentication>
                                    <login-module code="Remoting" flag="optional">
                                        <module-option name="password-stacking" value="useFirstPass"/>
                                    </login-module>
                                    <login-module code="RealmDirect" flag="required">
                                        <module-option name="password-stacking" value="useFirstPass"/>
                                    </login-module>
                                </authentication>
                            </security-domain>
                            <security-domain name="jboss-web-policy" cache-type="default">
                                <authorization>
                                    <policy-module code="Delegating" flag="required"/>
                                </authorization>
                            </security-domain>
                            <security-domain name="jboss-ejb-policy" cache-type="default">
                                <authorization>
                                    <policy-module code="Delegating" flag="required"/>
                                </authorization>
                            </security-domain>
                        </security-domains>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:threads:1.1"/>
                    <subsystem xmlns="urn:jboss:domain:transactions:1.3">
                        <core-environment>
                            <process-id>
                                <uuid/>
                            </process-id>
                        </core-environment>
                        <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>
                        <coordinator-environment default-timeout="300"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:web:1.4" default-virtual-server="default-host" native="false">
                        <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
                        <connector name="ajp" protocol="AJP/1.3" scheme="http" socket-binding="ajp"/>
                        <virtual-server name="default-host" enable-welcome-root="true">
                            <alias name="localhost"/>
                            <alias name="example.com"/>
                        </virtual-server>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:webservices:1.2">
                        <modify-wsdl-address>true</modify-wsdl-address>
                        <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>
                        <endpoint-config name="Standard-Endpoint-Config"/>
                        <endpoint-config name="Recording-Endpoint-Config">
                            <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">
                                <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>
                            </pre-handler-chain>
                        </endpoint-config>
                        <client-config name="Standard-Client-Config"/>
                    </subsystem>
                    <subsystem xmlns="urn:jboss:domain:weld:1.0"/>
                </profile>
                <interfaces>
                    <interface name="management">
                        <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>
                    </interface>
                    <interface name="public">
                        <inet-address value="${jboss.bind.address:127.0.0.1}"/>
                    </interface>
                    <!-- TODO - only show this if the jacorb subsystem is added  -->
                    <interface name="unsecure">
                        <!--
                          ~  Used for IIOP sockets in the standard configuration.
                          ~                  To secure JacORB you need to setup SSL 
                          -->
                        <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>
                    </interface>
                </interfaces>
                <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
                    <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>
                    <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
                    <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>
                    <socket-binding name="ajp" port="8009"/>
                    <socket-binding name="http" port="8080"/>
                    <socket-binding name="https" port="8443"/>
                    <socket-binding name="jacorb" interface="unsecure" port="3528"/>
                    <socket-binding name="jacorb-ssl" interface="unsecure" port="3529"/>
                    <socket-binding name="jgroups-mping" port="0" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45700"/>
                    <socket-binding name="jgroups-tcp" port="7600"/>
                    <socket-binding name="jgroups-tcp-fd" port="57600"/>
                    <socket-binding name="jgroups-udp" port="55200" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45688"/>
                    <socket-binding name="jgroups-udp-fd" port="54200"/>
                    <socket-binding name="messaging" port="5445"/>
                    <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:231.7.7.7}" multicast-port="${jboss.messaging.group.port:9876}"/>
                    <socket-binding name="messaging-throughput" port="5455"/>
                    <socket-binding name="modcluster" port="0" multicast-address="224.0.1.105" multicast-port="23364"/>
                    <socket-binding name="remoting" port="4447"/>
                    <socket-binding name="txn-recovery-environment" port="4712"/>
                    <socket-binding name="txn-status-manager" port="4713"/>
                    <outbound-socket-binding name="mail-smtp">
                        <remote-destination host="localhost" port="25"/>
                    </outbound-socket-binding>
                </socket-binding-group>
            </server>
            
            
            • 3. Re: Re: Listening to a Remote Topic In JBoss EAP 6.1
              Justin Bertram Master

              Since you have <resource-adapter-ref resource-adapter-name="hornetq-ra"/> then I would expect the container to wait until "hornetq-ra" is available before deploying your MDB, but apparently it isn't.  Try adding this to your MDB:

               

                @ResourceAdapter("hornetq-ra")

              • 4. Re: Re: Re: Listening to a Remote Topic In JBoss EAP 6.1
                Sankalp Madaan Newbie

                No, it did not work. Still getting the same problem while deploying. That was the configuration for remote Topic. The configuration where application is deployed is as follows:

                 

                <?xml version='1.0' encoding='UTF-8'?>
                
                
                <server xmlns="urn:jboss:domain:1.4">
                    <extensions>
                        <extension module="org.jboss.as.clustering.infinispan"/>
                        <extension module="org.jboss.as.clustering.jgroups"/>
                        <extension module="org.jboss.as.cmp"/>
                        <extension module="org.jboss.as.connector"/>
                        <extension module="org.jboss.as.deployment-scanner"/>
                        <extension module="org.jboss.as.ee"/>
                        <extension module="org.jboss.as.ejb3"/>
                        <extension module="org.jboss.as.jacorb"/>
                        <extension module="org.jboss.as.jaxr"/>
                        <extension module="org.jboss.as.jaxrs"/>
                        <extension module="org.jboss.as.jdr"/>
                        <extension module="org.jboss.as.jmx"/>
                        <extension module="org.jboss.as.jpa"/>
                        <extension module="org.jboss.as.jsf"/>
                        <extension module="org.jboss.as.jsr77"/>
                        <extension module="org.jboss.as.logging"/>
                        <extension module="org.jboss.as.mail"/>
                        <extension module="org.jboss.as.messaging"/>
                        <extension module="org.jboss.as.modcluster"/>
                        <extension module="org.jboss.as.naming"/>
                        <extension module="org.jboss.as.pojo"/>
                        <extension module="org.jboss.as.remoting"/>
                        <extension module="org.jboss.as.sar"/>
                        <extension module="org.jboss.as.security"/>
                        <extension module="org.jboss.as.threads"/>
                        <extension module="org.jboss.as.transactions"/>
                        <extension module="org.jboss.as.web"/>
                        <extension module="org.jboss.as.webservices"/>
                        <extension module="org.jboss.as.weld"/>
                    </extensions>
                    <management>
                        <security-realms>
                            <security-realm name="ManagementRealm">
                                <authentication>
                                    <local default-user="$local"/>
                                    <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>
                                </authentication>
                            </security-realm>
                            <security-realm name="ApplicationRealm">
                                <authentication>
                                    <local default-user="$local" allowed-users="*"/>
                                    <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>
                                </authentication>
                                <authorization>
                                    <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>
                                </authorization>
                            </security-realm>
                        </security-realms>
                        <management-interfaces>
                            <native-interface security-realm="ManagementRealm">
                                <socket-binding native="management-native"/>
                            </native-interface>
                            <http-interface security-realm="ManagementRealm">
                                <socket-binding http="management-http"/>
                            </http-interface>
                        </management-interfaces>
                    </management>
                    <profile>
                        <subsystem xmlns="urn:jboss:domain:logging:1.2">
                            <periodic-rotating-file-handler name="FILE" autoflush="true">
                                <formatter>
                                    <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>
                                </formatter>
                                <file relative-to="jboss.server.log.dir" path="server.log"/>
                                <suffix value=".yyyy-MM-dd"/>
                                <append value="true"/>
                            </periodic-rotating-file-handler>
                            <logger category="com.arjuna">
                                <level name="WARN"/>
                            </logger>
                            <logger category="org.apache.tomcat.util.modeler">
                                <level name="WARN"/>
                            </logger>
                            <logger category="org.jboss.as.config">
                                <level name="DEBUG"/>
                            </logger>
                            <logger category="sun.rmi">
                                <level name="WARN"/>
                            </logger>
                            <logger category="jacorb">
                                <level name="WARN"/>
                            </logger>
                            <logger category="jacorb.config">
                                <level name="ERROR"/>
                            </logger>
                            <root-logger>
                                <level name="INFO"/>
                                <handlers>
                                    <handler name="FILE"/>
                                </handlers>
                            </root-logger>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:cmp:1.1"/>
                        <subsystem xmlns="urn:jboss:domain:datasources:1.1">
                            <datasources>
                               <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="ExampleDS" enabled="true" use-java-context="true">
                                    <connection-url>jdbc:h2:mem:test;DB_CLOSE_DELAY=-1</connection-url>
                                    <driver>h2</driver>
                                    <security>
                                        <user-name>sa</user-name>
                                        <password>sa</password>
                                    </security>
                                </datasource>
                                <drivers>
                                    <driver name="h2" module="com.h2database.h2">
                                        <xa-datasource-class>org.h2.jdbcx.JdbcDataSource</xa-datasource-class>
                                    </driver>
                                </drivers>
                            </datasources>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">
                            <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="0"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:ee:1.1">
                            <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>
                            <jboss-descriptor-property-replacement>true</jboss-descriptor-property-replacement>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:ejb3:1.4">
                            <session-bean>
                                <stateless>
                                    <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>
                                </stateless>
                                <stateful default-access-timeout="5000" cache-ref="simple" clustered-cache-ref="clustered"/>
                                <singleton default-access-timeout="5000"/>
                            </session-bean>
                            <mdb>
                                <resource-adapter-ref resource-adapter-name="hornetq-ra"/>
                                <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>
                            </mdb>
                            <pools>
                                <bean-instance-pools>
                                    <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                                    <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
                                </bean-instance-pools>
                            </pools>
                            <caches>
                                <cache name="simple" aliases="NoPassivationCache"/>
                                <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>
                                <cache name="clustered" passivation-store-ref="infinispan" aliases="StatefulTreeCache"/>
                            </caches>
                            <passivation-stores>
                                <file-passivation-store name="file"/>
                                <cluster-passivation-store name="infinispan" cache-container="ejb"/>
                            </passivation-stores>
                            <async thread-pool-name="default"/>
                            <timer-service thread-pool-name="default">
                                <data-store path="timer-service-data" relative-to="jboss.server.data.dir"/>
                            </timer-service>
                            <remote connector-ref="remoting-connector" thread-pool-name="default"/>
                            <thread-pools>
                                <thread-pool name="default">
                                    <max-threads count="10"/>
                                    <keepalive-time time="100" unit="milliseconds"/>
                                </thread-pool>
                            </thread-pools>
                            <iiop enable-by-default="false" use-qualified-name="false"/>
                            <default-security-domain value="other"/>
                            <default-missing-method-permissions-deny-access value="true"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:infinispan:1.4">
                            <cache-container name="singleton" aliases="cluster ha-partition" default-cache="default">
                                <transport lock-timeout="60000"/>
                                <replicated-cache name="default" mode="SYNC" batching="true">
                                    <locking isolation="REPEATABLE_READ"/>
                                </replicated-cache>
                            </cache-container>
                            <cache-container name="web" aliases="standard-session-cache" default-cache="repl" module="org.jboss.as.clustering.web.infinispan">
                                <transport lock-timeout="60000"/>
                                <replicated-cache name="repl" mode="ASYNC" batching="true">
                                    <file-store/>
                                </replicated-cache>
                                <replicated-cache name="sso" mode="SYNC" batching="true"/>
                                <distributed-cache name="dist" mode="ASYNC" batching="true" l1-lifespan="0">
                                    <file-store/>
                                </distributed-cache>
                            </cache-container>
                            <cache-container name="ejb" aliases="sfsb sfsb-cache" default-cache="repl" module="org.jboss.as.clustering.ejb3.infinispan">
                                <transport lock-timeout="60000"/>
                                <replicated-cache name="repl" mode="ASYNC" batching="true">
                                    <eviction strategy="LRU" max-entries="10000"/>
                                    <file-store/>
                                </replicated-cache>
                                <!--
                                  ~  Clustered cache used internally by EJB subsytem for managing the client-mapping(s) of
                                  ~                 the socketbinding referenced by the EJB remoting connector 
                                  -->
                                <replicated-cache name="remote-connector-client-mappings" mode="SYNC" batching="true"/>
                                <distributed-cache name="dist" mode="ASYNC" batching="true" l1-lifespan="0">
                                    <eviction strategy="LRU" max-entries="10000"/>
                                    <file-store/>
                                </distributed-cache>
                            </cache-container>
                            <cache-container name="hibernate" default-cache="local-query" module="org.jboss.as.jpa.hibernate:4">
                                <transport lock-timeout="60000"/>
                                <local-cache name="local-query">
                                    <transaction mode="NONE"/>
                                    <eviction strategy="LRU" max-entries="10000"/>
                                    <expiration max-idle="100000"/>
                                </local-cache>
                                <invalidation-cache name="entity" mode="SYNC">
                                    <transaction mode="NON_XA"/>
                                    <eviction strategy="LRU" max-entries="10000"/>
                                    <expiration max-idle="100000"/>
                                </invalidation-cache>
                                <replicated-cache name="timestamps" mode="ASYNC">
                                    <transaction mode="NONE"/>
                                    <eviction strategy="NONE"/>
                                </replicated-cache>
                            </cache-container>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jacorb:1.3">
                            <orb socket-binding="jacorb" ssl-socket-binding="jacorb-ssl">
                                <initializers transactions="spec" security="identity"/>
                            </orb>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jaxr:1.1">
                            <connection-factory jndi-name="java:jboss/jaxr/ConnectionFactory"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:jca:1.1">
                            <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>
                            <bean-validation enabled="true"/>
                            <default-workmanager>
                                <short-running-threads>
                                    <core-threads count="50"/>
                                    <queue-length count="50"/>
                                    <max-threads count="50"/>
                                    <keepalive-time time="10" unit="seconds"/>
                                </short-running-threads>
                                <long-running-threads>
                                    <core-threads count="50"/>
                                    <queue-length count="50"/>
                                    <max-threads count="50"/>
                                    <keepalive-time time="10" unit="seconds"/>
                                </long-running-threads>
                            </default-workmanager>
                            <cached-connection-manager/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:jgroups:1.1" default-stack="udp">
                            <stack name="udp">
                                <transport type="UDP" socket-binding="jgroups-udp"/>
                                <protocol type="PING"/>
                                <protocol type="MERGE3"/>
                                <protocol type="FD_SOCK" socket-binding="jgroups-udp-fd"/>
                                <protocol type="FD"/>
                                <protocol type="VERIFY_SUSPECT"/>
                                <protocol type="pbcast.NAKACK"/>
                                <protocol type="UNICAST2"/>
                                <protocol type="pbcast.STABLE"/>
                                <protocol type="pbcast.GMS"/>
                                <protocol type="UFC"/>
                                <protocol type="MFC"/>
                                <protocol type="FRAG2"/>
                                <protocol type="RSVP"/>
                            </stack>
                            <stack name="tcp">
                                <transport type="TCP" socket-binding="jgroups-tcp"/>
                                <protocol type="MPING" socket-binding="jgroups-mping"/>
                                <protocol type="MERGE2"/>
                                <protocol type="FD_SOCK" socket-binding="jgroups-tcp-fd"/>
                                <protocol type="FD"/>
                                <protocol type="VERIFY_SUSPECT"/>
                                <protocol type="pbcast.NAKACK"/>
                                <protocol type="UNICAST2"/>
                                <protocol type="pbcast.STABLE"/>
                                <protocol type="pbcast.GMS"/>
                                <protocol type="UFC"/>
                                <protocol type="MFC"/>
                                <protocol type="FRAG2"/>
                                <protocol type="RSVP"/>
                            </stack>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jmx:1.2">
                            <expose-resolved-model/>
                            <expose-expression-model/>
                            <remoting-connector/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jpa:1.1">
                            <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:jsf:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:jsr77:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:mail:1.1">
                            <mail-session jndi-name="java:jboss/mail/Default">
                                <smtp-server outbound-socket-binding-ref="mail-smtp"/>
                            </mail-session>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:messaging:1.3">
                            <hornetq-server>
                                <cluster-password>${jboss.messaging.cluster.password:CHANGE ME!!}</cluster-password>
                                <persistence-enabled>true</persistence-enabled>
                                <journal-type>NIO</journal-type>
                                <journal-min-files>2</journal-min-files>
                                <connectors>
                                    <netty-connector name="netty" socket-binding="messaging"/>
                                    <netty-connector name="netty-throughput" socket-binding="messaging-throughput">
                                        <param key="batch-delay" value="50"/>
                                    </netty-connector>
                                    <in-vm-connector name="in-vm" server-id="0"/>
                                </connectors>
                                <acceptors>
                                    <netty-acceptor name="netty" socket-binding="messaging"/>
                                    <netty-acceptor name="netty-throughput" socket-binding="messaging-throughput">
                                        <param key="batch-delay" value="50"/>
                                        <param key="direct-deliver" value="false"/>
                                    </netty-acceptor>
                                    <in-vm-acceptor name="in-vm" server-id="0"/>
                                </acceptors>
                                <broadcast-groups>
                                    <broadcast-group name="bg-group1">
                                        <socket-binding>messaging-group</socket-binding>
                                        <broadcast-period>5000</broadcast-period>
                                        <connector-ref>netty</connector-ref>
                                    </broadcast-group>
                                </broadcast-groups>
                                <discovery-groups>
                                    <discovery-group name="dg-group1">
                                        <socket-binding>messaging-group</socket-binding>
                                        <refresh-timeout>10000</refresh-timeout>
                                    </discovery-group>
                                </discovery-groups>
                                <cluster-connections>
                                    <cluster-connection name="my-cluster">
                                        <address>jms</address>
                                        <connector-ref>netty</connector-ref>
                                        <discovery-group-ref discovery-group-name="dg-group1"/>
                                    </cluster-connection>
                                </cluster-connections>
                                <security-settings>
                                    <security-setting match="#">
                                        <permission type="send" roles="guest"/>
                                        <permission type="consume" roles="guest"/>
                                        <permission type="createNonDurableQueue" roles="guest"/>
                                        <permission type="deleteNonDurableQueue" roles="guest"/>
                                    </security-setting>
                                </security-settings>
                                <address-settings>
                                    <!--default for catch all-->
                                    <address-setting match="#">
                                        <dead-letter-address>jms.queue.DLQ</dead-letter-address>
                                        <expiry-address>jms.queue.ExpiryQueue</expiry-address>
                                        <redelivery-delay>0</redelivery-delay>
                                        <redistribution-delay>1000</redistribution-delay>
                                        <max-size-bytes>10485760</max-size-bytes>
                                        <address-full-policy>BLOCK</address-full-policy>
                                        <message-counter-history-day-limit>10</message-counter-history-day-limit>
                                    </address-setting>
                                </address-settings>
                                <jms-connection-factories>
                                    <connection-factory name="InVmConnectionFactory">
                                        <connectors>
                                            <connector-ref connector-name="in-vm"/>
                                        </connectors>
                                        <entries>
                                            <entry name="java:/ConnectionFactory"/>
                                        </entries>
                                    </connection-factory>
                                    <connection-factory name="RemoteConnectionFactory">
                                        <connectors>
                                            <connector-ref connector-name="netty"/>
                                        </connectors>
                                        <entries>
                                            <entry name="java:jboss/exported/jms/RemoteConnectionFactory"/>
                                        </entries>
                                        <ha>true</ha>
                                        <block-on-acknowledge>true</block-on-acknowledge>
                                        <retry-interval>1000</retry-interval>
                                        <retry-interval-multiplier>1.0</retry-interval-multiplier>
                                        <reconnect-attempts>-1</reconnect-attempts>
                                    </connection-factory>
                                    <pooled-connection-factory name="hornetq-ra">
                                        <transaction mode="xa"/>
                                        <connectors>
                                            <connector-ref connector-name="in-vm"/>
                                        </connectors>
                                        <entries>
                                            <entry name="java:/JmsXA"/>
                                        </entries>
                                    </pooled-connection-factory>
                                </jms-connection-factories>
                            </hornetq-server>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:modcluster:1.1">
                            <mod-cluster-config advertise-socket="modcluster" proxy-list="${jboss.modcluster.proxyList}" balancer="${jboss.modcluster.balancer}" connector="ajp">
                                <dynamic-load-provider>
                                    <load-metric type="busyness"/>
                                </dynamic-load-provider>
                            </mod-cluster-config>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:naming:1.3">
                            <remote-naming/>
                        </subsystem>
                       <!-- <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>-->
                        <subsystem xmlns="urn:jboss:domain:remoting:1.1">
                            <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:resource-adapters:1.1"/>
                        <subsystem xmlns="urn:jboss:domain:sar:1.0"/>
                        <subsystem xmlns="urn:jboss:domain:security:1.2">
                            <security-domains>
                                <security-domain name="other" cache-type="default">
                                    <authentication>
                                        <login-module code="Remoting" flag="optional">
                                            <module-option name="password-stacking" value="useFirstPass"/>
                                        </login-module>
                                        <login-module code="RealmDirect" flag="required">
                                            <module-option name="password-stacking" value="useFirstPass"/>
                                        </login-module>
                                    </authentication>
                                </security-domain>
                                <security-domain name="jboss-web-policy" cache-type="default">
                                    <authorization>
                                        <policy-module code="Delegating" flag="required"/>
                                    </authorization>
                                </security-domain>
                                <security-domain name="jboss-ejb-policy" cache-type="default">
                                    <authorization>
                                        <policy-module code="Delegating" flag="required"/>
                                    </authorization>
                                </security-domain>
                            </security-domains>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:threads:1.1"/>
                        <subsystem xmlns="urn:jboss:domain:transactions:1.3">
                            <core-environment>
                                <process-id>
                                    <uuid/>
                                </process-id>
                            </core-environment>
                            <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>
                            <coordinator-environment default-timeout="300"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:web:1.4" default-virtual-server="default-host" native="false">
                            <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>
                            <connector name="ajp" protocol="AJP/1.3" scheme="http" socket-binding="ajp"/>
                            <virtual-server name="default-host" enable-welcome-root="true">
                                <alias name="localhost"/>
                                <alias name="example.com"/>
                            </virtual-server>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:webservices:1.2">
                            <modify-wsdl-address>true</modify-wsdl-address>
                            <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>
                            <endpoint-config name="Standard-Endpoint-Config"/>
                            <endpoint-config name="Recording-Endpoint-Config">
                                <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">
                                    <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>
                                </pre-handler-chain>
                            </endpoint-config>
                            <client-config name="Standard-Client-Config"/>
                        </subsystem>
                        <subsystem xmlns="urn:jboss:domain:weld:1.0"/>
                    </profile>
                    <interfaces>
                        <interface name="management">
                            <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>
                        </interface>
                        <interface name="public">
                            <inet-address value="${jboss.bind.address:127.0.0.1}"/>
                        </interface>
                        <!-- TODO - only show this if the jacorb subsystem is added  -->
                        <interface name="unsecure">
                            <!--
                              ~  Used for IIOP sockets in the standard configuration.
                              ~                  To secure JacORB you need to setup SSL 
                              -->
                            <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>
                        </interface>
                    </interfaces>
                    <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">
                        <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>
                        <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
                        <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>
                        <socket-binding name="ajp" port="8009"/>
                        <socket-binding name="http" port="8080"/>
                        <socket-binding name="https" port="8443"/>
                        <socket-binding name="jacorb" interface="unsecure" port="3528"/>
                        <socket-binding name="jacorb-ssl" interface="unsecure" port="3529"/>
                        <socket-binding name="jgroups-mping" port="0" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45700"/>
                        <socket-binding name="jgroups-tcp" port="7600"/>
                        <socket-binding name="jgroups-tcp-fd" port="57600"/>
                        <socket-binding name="jgroups-udp" port="55200" multicast-address="${jboss.default.multicast.address:230.0.0.4}" multicast-port="45688"/>
                        <socket-binding name="jgroups-udp-fd" port="54200"/>
                        <socket-binding name="messaging" port="5445"/>
                        <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:231.7.7.7}" multicast-port="${jboss.messaging.group.port:9876}"/>
                        <socket-binding name="messaging-throughput" port="5455"/>
                        <socket-binding name="modcluster" port="0" multicast-address="224.0.1.105" multicast-port="23364"/>
                        <socket-binding name="remoting" port="4447"/>
                        <socket-binding name="txn-recovery-environment" port="4712"/>
                        <socket-binding name="txn-status-manager" port="4713"/>
                        <outbound-socket-binding name="mail-smtp">
                            <remote-destination host="localhost" port="25"/>
                        </outbound-socket-binding>
                    </socket-binding-group>
                </server>
                
                • 5. Re: Re: Re: Listening to a Remote Topic In JBoss EAP 6.1
                  Justin Bertram Master

                  Please attach some kind of project that I can use to reproduce this problem in an automated way.