0 Replies Latest reply on May 22, 2014 9:37 AM by Shailesh Londhe

    ERROR during the JBOSSWS-CXF configuration in existing JBOSS 5.1.2EAP

    Shailesh Londhe Newbie

      Hi,

      I am trying to configured JBOSSWS-CXF in existing JBOSS EAP and when i running the ant build-installer  it trying to connect to jboss reposiotry and i am getting below error

       

       

      Buildfile: /u01/jboss-eap-5.1/jboss-as/jbossws-cxf/build.xml

       

      prepare:

       

      os-init:

       

      prepare-deploy:

           [echo]

           [echo] mvn  package assembly:directory

           [echo]

           [exec] [INFO] Scanning for projects...

           [exec] Downloading: http://repository.jboss.org/maven2-brew/org/jboss/ws/jbossws-parent/1.0.8.GA/jbossws-parent-1.0.8.GA.pom

           [exec]

           [exec] Downloading: http://repository.jboss.org/maven2/org/jboss/ws/jbossws-parent/1.0.8.GA/jbossws-parent-1.0.8.GA.pom

           [exec] Downloading: http://snapshots.jboss.org/maven2/org/jboss/ws/jbossws-parent/1.0.8.GA/jbossws-parent-1.0.8.GA.pom

           [exec] Downloading: http://repo.maven.apache.org/maven2/org/jboss/ws/jbossws-parent/1.0.8.GA/jbossws-parent-1.0.8.GA.pom

           [exec] [ERROR] The build could not read 1 project -> [Help 1][ERROR]

           [exec] [ERROR]   The project org.jboss.ws.cxf:jbossws-cxf:3.1.2.SP9 (/u01/jboss-eap-5.1/jboss-as/jbossws-cxf/pom.xml) has 1 error

           [exec] [ERROR]     Non-resolvable parent POM: Could not transfer artifact org.jboss.ws:jbossws-parent:pom:1.0.8.GA from/to prod-repository.jboss.org (http://repository.jboss.org/maven2-brew): Access denied to: http://repository.jboss.org/maven2-brew/org/jboss/ws/jbossws-parent/1.0.8.GA/jbossws-parent-1.0.8.GA.pom , ReasonPhrase:Forbidden. and 'parent.relativePath' points at wrong local POM @ line 23, column 11 -> [Help 2]

           [exec] [ERROR]

           [exec] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

           [exec] [ERROR] Re-run Maven using the -X switch to enable full debug logging.

           [exec] [ERROR]

           [exec] [ERROR] For more information about the errors and possible solutions, please read the following articles:

           [exec] [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException

           [exec] [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException

       

      BUILD FAILED

      /u01/jboss-eap-5.1/jboss-as/jbossws-cxf/build.xml:95: exec returned: 1

       

      Total time: 8 seconds

       

      Can anybody give me resolution for this. urgent

       

       

      Thanks

      advance