0 Replies Latest reply on May 23, 2014 8:57 AM by Maximiliano de Mattos

    wildfly + Cannot load implementation of javax.naming.ldap.StartTlsResponse

    Maximiliano de Mattos Newbie

      Hi...

       

      Now I'm migrating aplications from jboss 4.2.3 (jee5) to wildfly 8 (jee7)... and for a cup of day I have this problem that I cannot resolve yet..

       

      In some lib (that interact with a LDAP server), to perform a secure connection, I have the following code:

       

      StartTlsResponse tls = (StartTlsResponse) this.ctx.extendedOperation(new StartTlsRequest());

       

      I recompile and test this library with jdk 7 and create a module in wildfly.

       

      Later, I deploy and activate de app (without error), but when I run it, a exception happens with the following description:

       

      Cannot load implementation of javax.naming.ldap.StartTlsResponse

       

      This exceptions is launched by javax.naming.ldap.StartTlsRequest, and I don't how to fix this!

       

      I try to load add some dependences on module descriptos (for example sun.jdk), tried other thinks  but nothing works

       

      Some idea?

       

      Thanks in advance