1 Reply Latest reply on Jun 3, 2014 6:40 AM by Darran Lofthouse

    jboss-cli.bat unable to connect locally- but able to connect remotely

    dave hoye Newbie

      From the local server, I am unable to connect using jboss-cli.bat:

       

      jboss-eap-6.2\bin>jboss-cli.bat --connect --controller=10.10.10.209:10199 --user=admin --password=adminadmin

      org.jboss.as.cli.CliInitializationException: Failed to connect to the controller

              at org.jboss.as.cli.impl.CliLauncher.initCommandContext(CliLauncher.java:284)

              at org.jboss.as.cli.impl.CliLauncher.main(CliLauncher.java:262)

              at org.jboss.as.cli.CommandLineMain.main(CommandLineMain.java:34)

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

              at java.lang.reflect.Method.invoke(Method.java:606)

              at org.jboss.modules.Module.run(Module.java:292)

              at org.jboss.modules.Main.main(Main.java:455)

      Caused by: org.jboss.as.cli.CommandLineException: The controller is not available at 10.10.10.209:10199

              at org.jboss.as.cli.impl.CommandContextImpl.tryConnection(CommandContextImpl.java:969)

              at org.jboss.as.cli.impl.CommandContextImpl.connectController(CommandContextImpl.java:808)

              at org.jboss.as.cli.impl.CommandContextImpl.connectController(CommandContextImpl.java:784)

              at org.jboss.as.cli.impl.CliLauncher.initCommandContext(CliLauncher.java:282)

              ... 8 more

      Caused by: java.io.IOException: java.net.ConnectException: JBAS012144: Could not connect to remote://10.10.10.209:10199. The connection timed ou

              at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeForResult(AbstractModelControllerClient.java:129)

              at org.jboss.as.controller.client.impl.AbstractModelControllerClient.execute(AbstractModelControllerClient.java:71)

              at org.jboss.as.cli.impl.CommandContextImpl.tryConnection(CommandContextImpl.java:947)

              ... 11 more

      Caused by: java.net.ConnectException: JBAS012144: Could not connect to remote://10.10.10.209:10199. The connection timed out

              at org.jboss.as.protocol.ProtocolConnectionUtils.connectSync(ProtocolConnectionUtils.java:131)

              at org.jboss.as.protocol.ProtocolConnectionManager$EstablishingConnection.connect(ProtocolConnectionManager.java:256)

              at org.jboss.as.protocol.ProtocolConnectionManager.connect(ProtocolConnectionManager.java:70)

              at org.jboss.as.protocol.mgmt.FutureManagementChannel$Establishing.getChannel(FutureManagementChannel.java:204)

              at org.jboss.as.cli.impl.CLIModelControllerClient.getOrCreateChannel(CLIModelControllerClient.java:160)

              at org.jboss.as.cli.impl.CLIModelControllerClient$2.getChannel(CLIModelControllerClient.java:120)

              at org.jboss.as.protocol.mgmt.ManagementChannelHandler.executeRequest(ManagementChannelHandler.java:117)

              at org.jboss.as.protocol.mgmt.ManagementChannelHandler.executeRequest(ManagementChannelHandler.java:92)

              at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeRequest(AbstractModelControllerClient.java:236)

              at org.jboss.as.controller.client.impl.AbstractModelControllerClient.execute(AbstractModelControllerClient.java:141)

              at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeForResult(AbstractModelControllerClient.java:127)

              ... 13 more

      Press any key to continue . . .

       

      I am able to telnet to the port using: telnet 10.10.10.209 10199

       

      But if I do the same from a remote host, it is able to connect:

       

      jboss-eap-6.2\bin>jboss-cli.bat --connect --controller=10.10.10.209:10199 --user=admin --password=adminadmin

      [standalone@10.10.10.209:10199 /]

       

      Is there a setting in our security realm that needs to be adjusted to allow local access to the CLI?

       

      dave