0 Replies Latest reply on Jun 4, 2014 12:27 PM by Sabarish Chandrasekharan

    I am trying to setup a SQLite database on my JBoss AS 7 server. But still not able to make it work. Below are the steps I followed, any suggestion or direction will be helpful.

    Sabarish Chandrasekharan Newbie

      Created a module for sqlite under JBOSSHOME/modules/org/xerial/sql-jdbc

      Under the folder dropped the sqlite-jdbc-3.6.0.jar and created a module.xml as below

      <module xmlns="urn:jboss:module:1.0" name="org.xerial.sqlite-jdbc">

          <resources>

              <resource-root path="sqlite-jdbc-3.6.0.jar"/>

          </resources>

          <dependencies>

              <module name="javax.api"/>

              <module name="javax.transaction.api"/>

          </dependencies>

      </module>

       

      Added the database entry into the standalone.xml as below

       

                     <datasource jndi-name="java:jboss/datasources/SQLiteDS" pool-name="SQLiteDSPool">

                          <connection-url>jdbc:sqlite:${jboss.server.base.dir}/opa.sqlite</connection-url>

                          <driver>sqlite</driver>

                      </datasource>

                      <drivers>

                        <driver name="sqlite" module="org.xerial.sqlite-jdbc"/>

                      </drivers>

       

      The .sqlite file is copied under the JBOSSHOME (/tools/jboss-as-web-7) directory (am using Mac OSX)

      Now when I start the server I get this error :

      12:12:20,976 INFO  [org.jboss.as.controller] (Controller Boot Thread) Service status report

         New missing/unsatisfied dependencies:

            service jboss.jdbc-driver.sqlite (missing)

       

      Am I missing anything here?