11 Replies Latest reply on Jun 20, 2014 3:48 AM by Radoslav Husar

    Problems when upgrade version 1.2.0 to 1.2.6

    Arturo Ibanez Newbie

      Dear guys,

       

      I had a big trouble with mod_cluster because when upgrade my version from 1.2.0-Final to 1.2.6-Final "dmesg" throw this error:

       

      httpd[14408]: segfault at 18 ip 00007f0f6e60c92e sp 00007f0f6d8bec88 error 4 in mod_manager.so[7f0f6e603000+e000]

       

      When i try to find more specifications for this error, i found this URL http://www.cyberciti.biz/tips/segmentation-fault-on-linux-unix.html but when i read this i think the problem perhaps must be a bug of mod_manager.

       

      I share for you my specs of my server (i had 2 VM and work with active-passive load balancing cluster behind heartbeat) :

       

      OS:      CentOS release 6.3 (Final)

      Architecture:          x86_64

      CPU op-mode(s):        32-bit, 64-bit

      Byte Order:            Little Endian

      CPU(s):                4

      CPU MHz:               2000.000

      Mem:         6 GB

      Swap:      2 GB

       

      And my httpd and mpm_worker_module important settings are :

       

      <IfModule mpm_worker_module>

          ThreadLimit         120

          ServerLimit 16

          StartServers        8

          MinSpareThreads     5

          MaxSpareThreads     20

          MaxClients          1920

          ThreadsPerChild     120

          MaxRequestsPerChild 16384

      </IfModule>


        <VirtualHost *:36666>

          KeepAliveTimeout 300

          MaxKeepAliveRequests 0

         AdvertiseFrequency 5

          EnableMCPMReceive

       

      Please any help will may work for me.

       

      Best regards