5 Replies Latest reply on Jun 16, 2014 8:47 AM by Wolf-Dieter Fink

    Jboss 5.1.0 GA start error

    Krishnamurthy KB Newbie

      Hi,

       

      I have installed Jboss 5.1.0 GA and trying to start the application server using startjboss.bat ...  when the below line is executed,

       

      net start "MBJBAS51SVC"

       

      the error "The service name is invalid" appears and the jboss server does not start at all. I have tried certain ways to get this resolved, like, stoping my firewall before installation of jboss, but without luck... can someone throw light on how to resolve this and possible reasons for this error. Thanks for your help.

       

      Content of startjboss.bat  ***********************************************************

       

      @echo off

       

       

      TITLE Application Server (JBoss 5.1.0.GA) : Port 9095

       

       

      ::: -- Set the window size --

      MODE CON: COLS=80 LINES=20 

       

       

      ::: -- Set the window color --

      COLOR 4F

       

       

      set AGENT=%CD%

      set ROOT=%AGENT%\..

       

       

      set JAVA_HOME=%ROOT%\Java

       

       

      cd %ROOT%\jboss\bin

       

       

      @echo on

      @echo Press 'Y' for running Application Server in debug mode within 5 sec.

      @echo ---------------------------------------------------------------------

       

       

      @echo off

      choice /c:YN /t 5 /d N

       

       

      IF errorlevel 2 goto NODEBUG

      IF errorlevel 1 goto DEBUG

       

       

      :DEBUG

      ECHO DEBUG

      net stop "MBJBAS51SVC"

       

       

      net start "MBJBAS51SVC"

       

       

      PING -n 10 127.0.0.1>nul

       

       

      cd %ROOT%\jboss\bin

      tail -100f ..\server\default\log\server.log

      goto EOF

       

       

       

       

      :NODEBUG

      ECHO NODEBUG

      net start "MBJBAS51SVC"

       

       

      @echo on

      @echo ---------------------------------------------------------------

      @echo. "...Wait for applications to be up. No key input required..."

      @echo ---------------------------------------------------------------

      @echo off

       

       

      :START

      findstr /C:"Started in" run.log

      if %errorlevel%==0 (

      @echo on

      @echo.

      @echo -----------------------------------------------------------------------------

      @echo *** Application Server - All Applications UP ***

      @echo You can close this window. JBoss running in TASKMGR

      @echo -----------------------------------------------------------------------------

      @echo.

      GOTO:END

      @echo off

      ) else (

      GOTO:START

      )

       

       

      :END

       

       

      :EOF

       

      Content of startjboss.bat  ***********************************************************

        • 1. Re: Jboss 5.1.0 GA start error
          Wolf-Dieter Fink Master

          It is not clear to me what you are doing.

          How JBoss is installed?

          Do you see log entries for the JBoss server?

           

          I suppose the service MBJBAS51SVC is not correct installed

          • 2. Re: Jboss 5.1.0 GA start error
            Krishnamurthy KB Newbie

            Jboss is installed as part of t24 software installation.

            where do i see the log entries - there is one log directory under c:\JBoss\server\default\log, however, there is no log written here for today's date

            • 3. Re: Jboss 5.1.0 GA start error
              Krishnamurthy KB Newbie

              I am still unable to start the Jboss 5.1 server. Attached is the log file that is generated when i start jboss server. One notable error in the log is as below... hope this is helps to narrow down to the issue.... thanks

               

              org.jboss.mx.server.MBeanServerImpl@2e9dca26[ defaultDomain='jboss' ]

              04:53:42,393 INFO  [ServerImpl] Runtime shutdown hook called, forceHalt: true

              04:53:42,395 WARN  [ProfileServiceBootstrap] Error deactivating profile: ProfileKey@627b5c[domain=default, server=default, name=default]

              org.jboss.profileservice.spi.NoSuchProfileException: No active profile for: ProfileKey@627b5c[domain=default, server=default, name=default]

                at org.jboss.system.server.profileservice.repository.AbstractProfileService.deactivateProfile(AbstractProfileService.java:391)

                at org.jboss.system.server.profileservice.ProfileServiceBootstrap.shutdown(ProfileServiceBootstrap.java:327)

                at org.jboss.bootstrap.AbstractServerImpl.shutdownServer(AbstractServerImpl.java:571)

                at org.jboss.bootstrap.AbstractServerImpl$ShutdownHook.run(AbstractServerImpl.java:909)

              • 4. Re: Jboss 5.1.0 GA start error
                Krishnamurthy KB Newbie

                Hi Wolf Dieter Fink,

                Thanks for your response.

                 

                I am still unable to start the Jboss 5.1 server. Attached is the log file that is generated when i start jboss server. One notable error in the log is as below... hope this is helps to narrow down to the issue.... thanks

                 

                org.jboss.mx.server.MBeanServerImpl@2e9dca26[ defaultDomain='jboss' ]

                04:53:42,393 INFO  [ServerImpl] Runtime shutdown hook called, forceHalt: true

                04:53:42,395 WARN  [ProfileServiceBootstrap] Error deactivating profile: ProfileKey@627b5c[domain=default, server=default, name=default]

                org.jboss.profileservice.spi.NoSuchProfileException: No active profile for: ProfileKey@627b5c[domain=default, server=default, name=default]

                  at org.jboss.system.server.profileservice.repository.AbstractProfileService.deactivateProfile(AbstractProfileService.java:391)

                  at org.jboss.system.server.profileservice.ProfileServiceBootstrap.shutdown(ProfileServiceBootstrap.java:327)

                  at org.jboss.bootstrap.AbstractServerImpl.shutdownServer(AbstractServerImpl.java:571)

                  at org.jboss.bootstrap.AbstractServerImpl$ShutdownHook.run(AbstractServerImpl.java:909)

                 

                Cheers

                Krishnamurthy

                • 5. Re: Jboss 5.1.0 GA start error
                  Wolf-Dieter Fink Master

                  Looks like a problem very early in the startup procedure. I suppose this is related to the Windows environment where you start JBoss as service.

                  Unfortunately my knowledge in that area is poor I've no idea.

                   

                  Is it possible to start the same installation with the run.bat script manually? This might clarify whether there is no jboss problem