0 Replies Latest reply on Jun 20, 2014 4:51 PM by D. Alvarado

    Getting 404s when visiting apps within https on my local JBoss instance

    D. Alvarado Newbie

      Hi,

       

       

      I’m having trouble configuring HTTPS on a local, dev instance of JBoss 7.1.3.  I was following the instructions here — https://docs.jboss.org/author/display/AS71/SSL+setup+guide .  In particular, I created a local keystone, added this in my $JBOSS_HOME/standalone/configuration/standalone.xml file:

       

       

      [code]

              <subsystem xmlns="urn:jboss:domain:web:1.2" default-virtual-server="default-host" native="false">

                  <configuration>

                      <jsp-configuration development="true"/>

                  </configuration>

                  <connector name="http" protocol="HTTP/1.1" scheme="http" socket-binding="http"/>

                  <connector name="https" scheme="https" protocol="HTTP/1.1" socket-binding="https" enable-lookups="false" secure="true">

                      <ssl name="dev-ssl" password="secret" protocol="TLSv1" key-alias="dev" certificate-key-file="../standalone/configuration/dev.keystore" />

                  </connector>

                  <virtual-server name="default-host" enable-welcome-root="true">

                      <alias name="localhost"/>

                      <alias name="example.com"/>

                  </virtual-server>

              </subsystem>

      [/code]

       

       

      and also added this

       

       

      [code]

          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

              <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>

              <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

              <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>

              <socket-binding name="ajp" port="8009"/>

              <socket-binding name="http" port="8080"/>

              <socket-binding name="https" port="8443"/>

      [/code]

       

       

      but when I restart my app server, and visit an app I have deployed, using https://localhost:8443/myapp/, I get a “Page Not Found” error from Jetty.  If I visit the same URL without https, e.g. http://localhost:8080/myapp/, my app comes up.  What else do I need to do to configure https successfully locally?