1 Reply Latest reply on Jun 24, 2014 8:29 AM by Radoslav Husar

    MOD_Cluster  in standalone error

    ismael Cad Newbie

      Hello

      I use mod_cluster 1.26, 2 server jboss AS 7.1.1 (nodeA and NodeB).

      In both file standalone i add :

       

      <subsystem xmlns="urn:jboss:domain:modcluster:1.0">

                  <mod-cluster-config advertise-socket="modcluster" proxy-list="127.0.0.1:7000">

                      <dynamic-load-provider>

                          <load-metric type="busyness"/>

                      </dynamic-load-provider>

                  </mod-cluster-config>

              </subsystem>

       

      and this is my httpdconf:

       

       

       

      LoadModule proxy_module modules/mod_proxy.so

      LoadModule proxy_ajp_module modules/mod_proxy_ajp.so

      LoadModule proxy_http_module modules/mod_proxy_http.so

      LoadModule proxy_cluster_module modules/mod_proxy_cluster.so

      LoadModule manager_module modules/mod_manager.so

      LoadModule slotmem_module modules/mod_slotmem.so

      LoadModule advertise_module modules/mod_advertise.so

       

       

      # MOD_CLUSTER_ADDS

      # Adjust to you hostname and subnet.

      <IfModule manager_module>

        Listen 127.0.0.1:7000

        ManagerBalancerName mycluster

        <VirtualHost 127.0.0.1:7000>

          <Location />

           Order deny,allow

           Deny from all

           Allow from 127.0.0.1

          </Location>

       

       

          KeepAliveTimeout 300

          MaxKeepAliveRequests 0

          #ServerAdvertise on http://127.0.0.1:6666

          AdvertiseFrequency 5

          #AdvertiseSecurityKey secret

          #AdvertiseGroup 224.0.1.105:23364

          EnableMCPMReceive

       

       

          <Location /mod_cluster_manager>

             SetHandler mod_cluster-manager

             Order deny,allow

             Deny from all

             Allow from 127.0.0

          </Location>

       

       

        </VirtualHost>

      </IfModule>

       

      when i  start my both jboss serveur :

      07:04:39,064 ERROR [org.jboss.modcluster.mcmp.impl.DefaultMCMPHandler] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) Error [null: null: {4}] sending command INFO to proxy 127.0.0.1/127.0.0.1:7000, configuration will be reset

       

      and acces to mod_cluster proxy 127.0.0.1:7000 its work but 127.0.0.1:7000/myAppli not work.

       

      If i put in only one file proxy-list="127.0.0.1:7000", i can acces to 127.0.0.1:7000/myAppli in only one node !

       

      Have you ideas to help me ?