0 Replies Latest reply on Jun 26, 2014 10:15 AM by Douglas Edey

    Migrating from JBoss  EAP 6.2 -> 6.3 Beta, DefaultInterceptorsClientContextInitializer not a subtype

    Douglas Edey Newbie

      I'm a new hire at my company and I've been tasked with changing the build system to be more flexible, as a test I'm trying to move from JBoss EAP 6.2 to 6.3 Beta. however the services (which I have not changed at all) not longer work, I get the following exception when services in a directory are being started.

       

      MSC000001: Failed to start service jboss.ejb3.dd-based-ejb-client-context."a.sar": org.jboss.msc

      .service.StartException in service jboss.ejb3.dd-based-ejb-client-context."a.sar": Failed to start service

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1936)

              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)

              at java.lang.Thread.run(Thread.java:744)

      Caused by: java.util.ServiceConfigurationError: org.jboss.ejb.client.EJBClientContextInitializer: Provider org.jboss.ejb.client.DefaultInterceptorsClientContextInitializer not a subtype

              at java.util.ServiceLoader.fail(ServiceLoader.java:231)

              at java.util.ServiceLoader.access$300(ServiceLoader.java:181)

              at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:369)

              at java.util.ServiceLoader$1.next(ServiceLoader.java:445)

              at org.jboss.ejb.client.EJBClientContext.init(EJBClientContext.java:121)

              at org.jboss.ejb.client.EJBClientContext.create(EJBClientContext.java:192)

              at org.jboss.as.ejb3.remote.DescriptorBasedEJBClientContextService.start(DescriptorBasedEJBClientContextService.java:109)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1980)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1913)

              ... 3 more

       

      I'm more used to the IBM JDK then the Oracle one, so I believe the error message is saying that DefaultInterceptorsClientContextInitializer doesn't implement EJBClientContextInitializer, but the source for the version of the DefaultInterceptorsClientContextInitializer on github for 1.0.25 shows that it is,  I'm trying to load the Jboss 6.3.0 Beta sources locally but I keep getting dependancy issues so it's slower than I expected it to be.

       

      Going back to the issue, I've dumped the verbose:classes and I can see that the classes are loaded from the JBoss 6.3.0 Beta version of the jboss ejb client.

       

      [Loaded org.jboss.ejb.client.EJBClientContextInitializer from jar:file:/<project>/modules/system/layers/base/org/jboss/ejb-client/main/jboss-ejb-client-1.0.25.Final-redhat-1.jar!/]

      [Loaded org.jboss.ejb.client.DefaultInterceptorsClientContextInitializer from jar:file:/<project>/jboss-eap/modules/system/layers/base/org/jboss/ejb-client/main/jboss-ejb-client-1.0.25.Final-redhat-1.jar!/]

       

      I'm not sure where to go next to determine what is causing this issue. Any advice would be appreciated.