9 Replies Latest reply on Jul 3, 2014 3:57 AM by nicolas duminil

    HTTP 404 - Can't find BPEL console

    nicolas duminil Master

      Hello,

       

      The document name "Red Hat JBoss Fuse Service Works 6 - Development Guide Volume 4: BPEL" is saying at the page 12 "Launch a web browser and navigate to http://localhost:8080/bpel-console". The problem is that no page exists at this URL and a "JBWEB000065 HTTP 404 The requested resource is not available" exception is raised. The FSW 6 server is running and I can connect to its admin console as well as to s-ramp, dt-gov, etc. Please let me know what's the problem here.

       

      Kind regards,

       

      Nicolas

        • 1. Re: HTTP 404 - Can't find BPEL console
          Keith Babo Master

          Any errors in the installation log?  Do you see switchyard-bpel-console.war and switchyard-bpel-console-server.war in the deployments directory of your install?  The BPEL console is available at that address in my FSW install.  If there are no errors in the install log and both those deployments are successful (.deployed file also present), then I would file a support case to help troubleshoot the install.

          1 of 1 people found this helpful
          • 2. Re: HTTP 404 - Can't find BPEL console
            nicolas duminil Master

            Hello Keith,

             

            Thank you for your reply. There is only one error message in the log file:

             

            17:33:00,800 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss Red Hat JBoss Fuse Service Works 6.0.0.GA-redhat-2 (AS 7.2.1.Final-redhat-10) a démarré (avec des erreurs) en 12534ms - 925 des services 1035 démarré(s) (4 services ont échoué ou manquent de dépendances, 100 services sont passifs ou à la demande)

             

            it is saying that on the 1035 services, 925 have started correctly, 4 have failed and 100 are on-demand services. There is no any other ERROR in the log file and I cannot identify thar 4 failing services, but I got that:

             

            JBAS014775: Nouvelles dépendances manquantes/non complétées :

            Dépendances service jboss.module.spec.service."deployment.overlord-rtgov.war".main (manquantes) : [service jboss.module.service."deployment.overlord-rtgov-epn.war".main, service jboss.module.service."deployment.overlord-rtgov-acs.war".main, service jboss.module.resolve.phase."deployment.overlord-rtgov-epn.war".main.1, service jboss.module.resolve.phase."deployment.overlord-rtgov-acs.war".main.1]

            Dépendances service module.resolved.service."deployment.overlord-rtgov-acs.war".main (manquantes) : [service jboss.module.service."deployment.overlord-rtgov-acs.war".main]

            Dépendances service module.resolved.service."deployment.overlord-rtgov-epn.war".main (manquantes) : [service jboss.module.service."deployment.overlord-rtgov-epn.war".main]

             

            This is saying that there are new missing dependencies related, as far as I understand, to overlord-rtgov-acs.war and overlord-rtgov-epn.war. Does it make any sense ?

             

            Many thanks in advance.

             

            Nicolas

            1 of 1 people found this helpful
            • 3. Re: HTTP 404 - Can't find BPEL console
              nicolas duminil Master

              Hello Keith,

               

              I'm updating the case based on the last developments and testing I did. After having started the FSW server and noticed that the 4 mentioned services didn't start due to some missing dependencies, I noticed also that switchyard-bpel-console.war, while present in the deployments directory, was not deployed. I tried to deploy it manually and this time the following exception appeared in the log file:

               

              12:52:09,543 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/bpel-console].[ErraiServlet]] (http-localhost/127.0.0.1:8080-11) JBWEB000235: Allocate exception for servlet ErraiServlet: java.util.MissingResourceException: Can't find bundle for base name org.jboss.errai.bus.ErraiService, locale fr_FR

                  at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499) [rt.jar:1.7.0_11]

                  at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322) [rt.jar:1.7.0_11]

                  at java.util.ResourceBundle.getBundle(ResourceBundle.java:724) [rt.jar:1.7.0_11]

                  at org.jboss.errai.bus.server.service.ErraiServiceConfiguratorImpl.loadServiceProperties(ErraiServiceConfiguratorImpl.java:78) [errai-bus-1.1-Final.jar:1.1-Final]

                  at org.jboss.errai.bus.server.service.ErraiServiceConfiguratorImpl.<init>(ErraiServiceConfiguratorImpl.java:59) [errai-bus-1.1-Final.jar:1.1-Final]

                  at org.jboss.errai.bus.server.service.ErraiServiceConfiguratorImpl$$FastClassByGuice$$b6139751.newInstance(<generated>)

                  at com.google.inject.internal.cglib.reflect.FastConstructor.newInstance(FastConstructor.java:40) [guice-2.0.jar:]

                  at com.google.inject.DefaultConstructionProxyFactory$1.newInstance(DefaultConstructionProxyFactory.java:60) [guice-2.0.jar:]

                  at com.google.inject.ConstructorInjector.construct(ConstructorInjector.java:85) [guice-2.0.jar:]

                  at com.google.inject.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:111) [guice-2.0.jar:]

                  at com.google.inject.FactoryProxy.get(FactoryProxy.java:56) [guice-2.0.jar:]

                  at com.google.inject.SingleParameterInjector.inject(SingleParameterInjector.java:42) [guice-2.0.jar:]

                  at com.google.inject.SingleParameterInjector.getAll(SingleParameterInjector.java:66) [guice-2.0.jar:]

                  at com.google.inject.ConstructorInjector.construct(ConstructorInjector.java:84) [guice-2.0.jar:]

                  at com.google.inject.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:111) [guice-2.0.jar:]

                  at com.google.inject.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:45) [guice-2.0.jar:]

                  at com.google.inject.InjectorImpl.callInContext(InjectorImpl.java:811) [guice-2.0.jar:]

                  at com.google.inject.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:42) [guice-2.0.jar:]

                  at com.google.inject.Scopes$1$1.get(Scopes.java:54) [guice-2.0.jar:]

                  at com.google.inject.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:48) [guice-2.0.jar:]

                  at com.google.inject.FactoryProxy.get(FactoryProxy.java:56) [guice-2.0.jar:]

                  at com.google.inject.InjectorImpl$4$1.call(InjectorImpl.java:758) [guice-2.0.jar:]

                  at com.google.inject.InjectorImpl.callInContext(InjectorImpl.java:804) [guice-2.0.jar:]

                  at com.google.inject.InjectorImpl$4.get(InjectorImpl.java:754) [guice-2.0.jar:]

                  at com.google.inject.InjectorImpl.getInstance(InjectorImpl.java:793) [guice-2.0.jar:]

                  at org.jboss.errai.bus.server.servlet.AbstractErraiServlet.buildService(AbstractErraiServlet.java:133) [errai-bus-1.1-Final.jar:1.1-Final]

                  at org.jboss.errai.bus.server.servlet.AbstractErraiServlet.init(AbstractErraiServlet.java:104) [errai-bus-1.1-Final.jar:1.1-Final]

                  at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1194) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:950) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:151) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:499) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169) [jboss-as-web-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]

                  at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920) [jbossweb-7.2.2.Final-redhat-1.jar:7.2.2.Final-redhat-1]

                  at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_11]

               

              I probably forgot to mention that my locale is fr_FR. However, my installation is a standard one, done through the FSW installer and hence supposed to work whatever the locale and the OS is. Is there any post-install operation that needs to be done in order to add the missing fr_FR bundle ?

               

              Many thanks in advance,

               

              Nicolas

              • 4. Re: HTTP 404 - Can't find BPEL console
                Gary Brown Master

                Hi Nicolas

                 

                Yes, this should work - so can you please contact support to create a product bug report.

                 

                Regards

                Gary

                • 5. Re: HTTP 404 - Can't find BPEL console
                  nicolas duminil Master

                  I thought that by posting here I was contacting the support ...

                  • 6. Re: HTTP 404 - Can't find BPEL console
                    Gary Brown Master

                    No, this is a forum for the community project.

                    • 7. Re: HTTP 404 - Can't find BPEL console
                      Rick Wagner Newbie

                      Hi Nicolas,

                       

                      I'm a support engineer with JBoss, I can help you find the way.

                       

                      This forum is a 'Community' resource.  That means it's monitored and worked by 'Community, Open Source' personnel.  These folks are great, among the greatest developers in the world.  But they don't have SLAs associated with their responses, and they are under no commitment to address any issues.  (If you choose to become an active Community member, you can make great contributions in areas you see fit.  But you can only user persuasive techniques to get others to help you, you can't 'order' anybody to do anything.)the

                       

                      There is a better way to get responses if you desire.  If you purchase the Red Hat commercial product that corresponds to the Open Source project you want supported, then you get the 'gold' level of service.  (It costs money).  With a commercial software subscription you get a professional support staff the has members around the globe, you get a ticketing system and phone numbers you can call to get real people on the line, and you get SLAs that guarantee you'll get responses in a timely manner.  Further, when a paying customer has a problem, Red Hat makes sure the problem gets addressed.  If you're using open source for your place of business, the modest cost of a license can buy a lot of peace of mind.

                       

                      I hope that helps, and thank you for using JBoss products no matter which use is best for you.

                       

                      Regards,

                       

                      Rick

                      • 8. Re: HTTP 404 - Can't find BPEL console
                        Eric Wittmann Apprentice

                        Nicholas, can you try to locate the ErraiService.properties file in your installation?  For example, mine is here:

                         

                        $ pwd ; find . -name 'ErraiService.properties'

                        /home/ewittman/tmp/fsw-6.0/jboss-eap-6.1/standalone/deployments/switchyard-bpel-console.war

                        ./WEB-INF/classes/ErraiService.properties

                        • 9. Re: HTTP 404 - Can't find BPEL console
                          nicolas duminil Master

                          Hi Eric,

                           

                          Yes, as a matter of fact, the mentioned file exists at the mentioned location. But looking inside it I didn't find anything which could have made me think at any relation with the locale.

                           

                          Kind regards,

                           

                          Nicolas DUMINIL