5 Replies Latest reply on Aug 8, 2014 11:48 AM by Jason Porter

    seam jsf page hang or not rendered

    Ram Gopal Newbie

      Hi

       

      We have a application ( screens mostly generated by seam-gen tool)

      It is a user inbox functionality where user clicks on a case, case detail is opened in a new tab.

      Some time, the case detail page is not getting rendered to user browser. i.e. the request is hang and after sometime browser times out.

       

      Before browser time outs, even if I close the hanging tab and clicks again on the same case, It still hangs. Any number of times I try, getting the same result.

      But without closing the hang tab, if I click on the same case at Inbox, it opens up case detail properly in a new tab.

       

      Single click on a case at Inbox in fact triggers 4 URL redirection normally but in the hang scenario the first URL goes out and hangs.

       

      Webserver access log shows "200 OK" for all 4 URLs typically associated with each click.

      No error/exception found in the application log as well.

       

      Can anyone please help how we can fix this issue ?

       

      Each of our users are facing this issue daily few times

       

      Thanks & Rgds,

      Ram

        • 1. Re: seam jsf page hang or not rendered
          Jason Porter Master

          How deep have you going with debugging? Do you know if it's a db issue or application logic? It also sounds like you're using Seam 2, correct? Are there pessimistic locks in the database or are they all optimistic?

          • 2. Re: seam jsf page hang or not rendered
            Ram Gopal Newbie

            Hi Jason,

             

            Sorry for the delay, I was out of action for couple of weeks.

             

            We are using seem 2 (G.A.)

            Our debugging is not so deep. 

             

            I am not sure about what kind of locks there in database.

            Actually it involves only querying tables for data but no writing.

             

            Below is the kind of access URL log we are getting  (the portion at 8:39 is when it hangs and 8:42 portion is success)

            We don't see any error or exception at application log.

            What it appears is that for some reason, seam could complete the writing the response to the output stream

             

            It's a simple s:link call and the "conversion is not started". It will be started only after the page is successfully loaded.

            Will beginning conversation help to over come this?

             

            "<s:link id="register" view="/register.xhtml" value="Register New User" propagation="begin"/>"

             

            Thanks,

            Ram

             

             

            ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

            [29/Jul/2014:08:39:44 +0000] "GET /MYAPP/pages/common/redirectSubmission.seam?submissionNumber=SUB2014060312 HTTP/1.1" 200 1573

            [29/Jul/2014:08:39:47 +0000] "GET /MYAPP/pages/bpme/WithdrawalProcess.seam?withdrawalSubmissionNumber=SUB2014060312&SubmissionNumber=SUB2014060312&viewType=Process&viewId=Withdrawal HTTP/1.1" 200 422252

            [29/Jul/2014:08:39:49 +0000] "GET /MYAPP/pages/common/projectTree.seam?SubmissionNumber=SUB2014060312 HTTP/1.1" 200 561025

            [29/Jul/2014:08:39:53 +0000] "POST /MYAPP/pages/common/projectTree.seam HTTP/1.1" 200 346175

            ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

            [29/Jul/2014:08:42:38 +0000] "POST /MYAPP/pages/common/projectTree.seam HTTP/1.1" 200 21281

            [29/Jul/2014:08:42:38 +0000] "POST /MYAPP/pages/common/projectTree.seam?_richfaces_upload_uid=0.8182417732662327&fileUploadForm:j_id20=fileUploadForm:j_id20&_richfaces_upload_file_indicator=true&AJAXREQUEST=_viewRoot HTTP/1.1" 200 21017

            [29/Jul/2014:08:42:40 +0000] "POST /MYAPP/pages/common/projectTree.seam HTTP/1.1" 200 527931

            [29/Jul/2014:08:42:44 +0000] "GET /MYAPP/pages/bpme/WithdrawalProcess.seam?withdrawalSubmissionNumber=SUB2014060312&SubmissionNumber=SUB2014060312&viewType=Process&viewId=Withdrawal HTTP/1.1" 200 422252

            [29/Jul/2014:08:42:46 +0000] "GET /MYAPP/pages/common/projectTree.seam?SubmissionNumber=SUB2014060312 HTTP/1.1" 200 578448

            ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

            • 3. Re: seam jsf page hang or not rendered
              Jason Porter Master

              Hrm, not much to go off. What exactly is the version of Seam 2 you're using? Beginning the conversation at the start may help. Are you doing some bpm stuff?

              • 4. Re: seam jsf page hang or not rendered
                Ram Gopal Newbie

                Seam2 version we are using is 2.2.0.1

                 

                We are not doing seam BPM stuff ...

                We use FielNet BPM which is deployed in a separate box

                 

                The rendering of the page depends on a FileNet communication where it has to return the list of document names (not actual documents) for the project which is constructed as a project tree structure before rendering.

                 

                Thanks & Rgds,

                Ram

                • 5. Re: seam jsf page hang or not rendered
                  Jason Porter Master

                  Sounds like that communication with FileNet is probably the slowdown.