3 Replies Latest reply on Jul 14, 2004 10:58 AM by Marcus Schiesser

    strange invalid data problem

    Marcus Schiesser Newbie

      hi folks,

      i have a ejb application (http://www.molimo.de) running under jboss 3.2.4. after deployment everything works fine. after some time (maybe 10 user sessions) - the local CMP beans return invalid data.
      i changed the databases - same result.
      i tried it with and without cache invalidation - also same result.
      i can trace down the problem to the field getter of one of the local beans - sometimes it returns different values (altough the value in the database never changes).
      could it be, that there is a problem with the transaction descriptor?
      i set all methods of the local beans to mandatory and the session beans to required, so they should start a new transaction if no one exists.
      Any hint? sorry, if the problem description is a bit inaccurate - i hope someone can help me anyway. The whole source of the application is available under the web site above (GPL) and if the origin of the problem depends on jboss i am willing to help also.

      thanks,

      marcus