1 Reply Latest reply on Jul 18, 2014 6:04 PM by Justin Bertram

    Classloading problem with JBoss 6.1 and HornetQ

    Ken Howard Newbie

      I am relatively new to JBoss and I'm having trouble with class loading similar to what is described in this post. I was able to solve the issue using the code solution described in the post. Namely replacing the class loader with a previously saved class loader.  However I really don't want to solve it this way.  I'm hopeful that there may be a configuration solution to this though I just don't know what it is.

        • 1. Re: Classloading problem with JBoss 6.1 and HornetQ
          Justin Bertram Master

          Couple of things...

          1. I moved your post from the HornetQ Development forum (meant for discussion about the development of HornetQ itself) to the HornetQ User forum (meant for discussions about using HornetQ).
          2. Can you be more specific about the issue you're facing?  The linked forum post is regarding a classloading issue when using an un-managed message listener in a Java EE container.  Are you using an un-managed message listener in JBoss EAP 6.1 and hitting a classloading problem?  If so, I think the code solution outlined there would probably be your best solution.  The issue here is that since the message listener is un-managed the container is not able to make an intelligent choice about what classloader to set for it (something which is done for message driven beans which are managed message listeners) so you have to do it manually.  Another way to solve this would be to not use un-managed message listeners in the container.  In my opinion they are generally not a good idea anyway.