1 Reply Latest reply on Jul 24, 2014 2:24 PM by Keith Babo

    SY 1.1 with Camel 2.13

    Zoul AKHDAR Newbie

      Hi there,

       

      I'm new with SY and i have a 'little problem' , i need to use JSonPath  (http://camel.apache.org/jsonpath.html) in a java based camel route component/implementation to do something like this :

       

      from("queue:books.new")

       

        .choice()

          .when().jsonpath("$.store.book[?(@.price < 10)]")

            .to("jms:queue:book.cheap")

          .when().jsonpath("$.store.book[?(@.price < 30)]")

            .to("jms:queue:book.average")

          .otherwise()

            .to("jms:queue:book.expensive")

      i'm using JBoss EAP 6.1 and SY 1.1 (Camel 2.1 is shipped with SY1.1) the problem is JSonPath is available since Camel 2.13.

      My question is, it's possible to update SY1.1 with Camel 2.13 ?

       

      In the same way my application need to use OptaPlanner (Camel provide this component) but in 2.13 version.

       

      thanks