2 Replies Latest reply on Jul 23, 2014 2:13 AM by Wolf-Dieter Fink

    ear causes: java.lang.NoClassDefFoundError: oracle/sql/CLOB

    tithi biswas Newbie


      Hi All,

      I am facing an issue in accessing jdbc calls inside ear that is deployed in jboss eap 6. I have created an ejb project (Message Driven Bean) that will read messages from jboss queue and read them into database using jdbc calls. In the jdbc code I am using oracle.sql.clob. I created the ear from ejb project through eclipse and ear was successfully deployed in jboss. but when it tries to insert the message in database I am getting java.lang.NoClassDefFoundError: oracle/sql/CLOB. I tried the following but none of them worked for me. Please suggest if anyone has ever faced this issue.

      1. included the ojdbc6.jar in ear creation. (added inside ear content of EAR in eclipse and also METAINF)

      2.added module dependency in jboss-deployment-structure.xml :  and did not include the jar in ear creation and not added the jar in jboss/standalone/lib

      <dependencies>

      <module name="com.oracle.ojdbc6"/>

      </dependencies>

      3. tried to add the jar in jboss/standalone/lib and included the jar in ear creation.

       

      Thanks