5 Replies Latest reply on Aug 19, 2014 12:31 AM by Max Rydahl Andersen

    wildfly 8.1 deployment-scanner issue, multiple created when started from Eclipse Luna

    Daniel O'Leary Newbie

      When I look in standalone.xml, I see one deployment scanner:

              <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000"/>

       

      When I start the server, I another deployment-scanner is created:

              <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000"/>
              <deployment-scanner name="jbosstoolsscanner1" path="C:\development\opt\wildfly-8.1.0.Final\standalone\deployments" scan-interval="5000" deployment-timeout="600"/>

       

      When I run an app on the server, I get the following behaviour:

      09:42:17,106 INFO  [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found WET_4.0_Combined.war in deployment directory. To trigger deployment create a file called WET_4.0_Combined.war.dodeploy

      09:42:17,143 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015876: Starting deployment of "WET_4.0_Combined.war" (runtime-name: "WET_4.0_Combined.war")

      09:42:17,513 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-3) JBAS017534: Registered web context: /WET_4.0

      09:42:17,714 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "WET_4.0_Combined.war" (runtime-name : "WET_4.0_Combined.war")

      09:42:19,002 INFO  [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) JBAS015003: Found WET_4.0_Combined.war in deployment directory. To trigger deployment create a file called WET_4.0_Combined.war.dodeploy

      09:42:22,746 INFO  [org.wildfly.extension.undertow] (MSC service thread 1-1) JBAS017535: Unregistered web context: /WET_4.0

      09:42:22,770 INFO  [org.hibernate.validator.internal.util.Version] (MSC service thread 1-6) HV000001: Hibernate Validator 5.1.0.Final

      09:42:22,810 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-3) JBAS015877: Stopped deployment WET_4.0_Combined.war (runtime-name: WET_4.0_Combined.war) in 68ms

      09:42:23,514 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018558: Undeployed "WET_4.0_Combined.war" (runtime-name: "WET_4.0_Combined.war")

      09:42:28,522 INFO  [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found WET_4.0_Combined.war in deployment directory. To trigger deployment create a file called WET_4.0_Combined.war.dodeploy

       

      When I stop the server, the jbosstoolsscanner1 deployment scanner is removed.

       

      What is causing this, and how do I resolve it?