11 Replies Latest reply on Jun 9, 2016 7:29 PM by George Gastaldi

    Wildfly 8.1 ActiveMQ Integration Issue

    Matt Madhavan Newbie

      Hello,

      I am trying to integrate ActiveMQ as a Wildfly module. I am following the following article

      How to Use Out of Process ActiveMQ with WildFly

       

      However when I start the WildFly, I am not able to integrate ActiveMQ. I am getting the following error.

       

      15:06:09,353 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 43) JBAS014613: Operation ("add") failed - address: ([

          ("subsystem" => "resource-adapters"),

          ("resource-adapter" => "activemq-ra.rar")

      ]) - failure description: "JBAS010473: Failed to load module for RA [org.apache.activemq.ra]"

       

      Any ideas please?

       

      Thanks in advance!

      Matt

        • 1. Re: Wildfly 8.1 ActiveMQ Integration Issue
          Jeff Mesnil Master

          Given your failure, it is likely that the org.apache.activemq.ra module has not been defined correctly.

           

          Coud you paste your module layout as well as the content of its module.xml file?

          • 2. Re: Wildfly 8.1 ActiveMQ Integration Issue
            Matt Madhavan Newbie

            HI Jeff,

            Thank you very much for your reply!

             

            My module location is :

            \wildfly-8.1.0.Final\modules\system\layers\base\org\apache\activemq\main

             

            The following is the list of all the files:

            activemq_ra.png

             

            The content of my module.xml is:

            module.png

             

             

            My standalnon.xml is identical to the link I had posted in my original post. (Please see above).

             

            Any ideas?

             

            Meanwhile if you are running avtivermq under JBoss, is there any way I can a zipped version of your module and standalone.xml please?

             

            Thanks in advance.1

            Matt

            • 3. Re: Wildfly 8.1 ActiveMQ Integration Issue
              Jeff Mesnil Master

              Make sure that you remove all files in the module directory that are not listed in module.xml, especially the broker-config.xml and META-INF directory.

              1 of 1 people found this helpful
              • 4. Re: Wildfly 8.1 ActiveMQ Integration Issue
                Michal Kopeć Newbie

                Configuration that worked for me (version 5.10 but 5.9 is very similar (some library versions are different in RA))

                 

                
                <module xmlns="urn:jboss:module:1.3" name="org.apache.activemq" slot="5.10" >
                    <resources>
                
                        <resource-root path="."/>
                        <resource-root path="activemq-broker-5.10.0.jar"/>
                        <resource-root path="activemq-client-5.10.0.jar"/>
                        <resource-root path="activemq-jms-pool-5.10.0.jar"/>
                        <resource-root path="activemq-kahadb-store-5.10.0.jar"/>
                        <resource-root path="activemq-openwire-legacy-5.10.0.jar"/>
                        <resource-root path="activemq-pool-5.10.0.jar"/>
                        <resource-root path="activemq-protobuf-1.1.jar"/>
                        <resource-root path="activemq-ra-5.10.0.jar"/>
                        <resource-root path="activemq-spring-5.10.0.jar"/>
                        <resource-root path="aopalliance-1.0.jar"/>
                        <resource-root path="commons-pool-1.6.jar"/>
                        <resource-root path="commons-logging-1.1.3.jar"/>
                        <resource-root path="hawtbuf-1.10.jar"/>
                        <resource-root path="spring-aop-3.2.8.RELEASE.jar"/>
                        <resource-root path="spring-beans-3.2.8.RELEASE.jar"/>
                        <resource-root path="spring-context-3.2.8.RELEASE.jar"/>
                        <resource-root path="spring-core-3.2.8.RELEASE.jar"/>
                        <resource-root path="spring-expression-3.2.8.RELEASE.jar"/>
                        <resource-root path="xbean-spring-3.16.jar"/>
                    </resources>
                    <exports>
                
                        <exclude path="org/springframework/**"/>
                        <exclude path="org/apache/xbean/**"/>
                        <exclude path="org/apache/commons/**"/>
                        <exclude path="org/aopalliance/**"/>
                        <exclude path="org/fusesource/**"/>
                
                    </exports>
                
                    <dependencies>
                
                        <module name="javax.api"/>
                        <module name="org.slf4j"/>
                        <module name="javax.resource.api"/>
                        <module name="javax.jms.api"/>
                        <module name="javax.management.j2ee.api"/>
                
                    </dependencies>
                
                </module>
                
                

                 

                 

                Standalone XML (standalone-full.xml)

                 

                <subsystem xmlns="urn:jboss:domain:resource-adapters:2.0">
                   <resource-adapters>
                      <resource-adapter id="activemq-rar.rar">
                         <module slot="5.10" id="org.apache.activemq"/>
                         <transaction-support>NoTransaction</transaction-support>
                         <config-property name="ServerUrl">tcp://xxx.xxx.xxx.xxx:61616</config-property>
                         <connection-definitions>
                            <connection-definition class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory" jndi-name="java:/AMQConnectionFactory" enabled="true" use-java-context="true" pool-name="AMQConnectionFactory"/>
                         </connection-definitions>
                         <admin-objects>
                            <admin-object class-name="org.apache.activemq.command.ActiveMQQueue" jndi-name="java:jboss/test" use-java-context="true" pool-name="target_queue">
                               <config-property name="PhysicalName">test</config-property>
                            </admin-object>
                         </admin-objects>
                      </resource-adapter>
                   </resource-adapters>
                </subsystem>
                
                
                • 5. Re: Wildfly 8.1 ActiveMQ Integration Issue
                  Matt Madhavan Newbie

                  Hummm....

                  Thanks for the reply! All I did was to remove all the files that were not part of the module.xml. It worked like a charm. Thannk you all!

                   

                  Matt

                  • 6. Re: Wildfly 8.1 ActiveMQ Integration Issue
                    Frank Ecsedy Newbie

                    Same issue, except I am using activemq 5.9.0. The solution that solved the original poster's issue did not work for me. Here is my directory:

                     

                    Directory of C:\opt\jboss\current\modules\system\layers\base\org\apache\activemq\main

                     

                    08/08/2014  02:00 PM         1,002,495 activemq-broker-5.9.0.jar

                    08/08/2014  02:00 PM         1,165,912 activemq-client-5.9.0.jar

                    08/08/2014  02:00 PM            47,565 activemq-jms-pool-5.9.0.jar

                    08/08/2014  02:00 PM           539,427 activemq-kahadb-store-5.9.0.jar

                    08/08/2014  02:00 PM           685,801 activemq-openwire-legacy-5.9.0.jar

                    08/08/2014  02:00 PM            19,481 activemq-pool-5.9.0.jar

                    08/08/2014  02:00 PM           147,874 activemq-protobuf-1.1.jar

                    08/08/2014  02:00 PM            88,703 activemq-ra-5.9.0.jar

                    08/08/2014  02:00 PM           160,352 activemq-spring-5.9.0.jar

                    08/08/2014  02:00 PM             4,467 aopalliance-1.0.jar

                    08/08/2014  02:00 PM           280,983 commons-net-3.3.jar

                    08/08/2014  02:00 PM            50,139 hawtbuf-1.9.jar

                    08/11/2014  04:09 PM             1,582 module.xml

                    08/08/2014  02:00 PM           335,455 spring-aop-3.2.4.RELEASE.jar

                    08/08/2014  02:00 PM           607,755 spring-beans-3.2.4.RELEASE.jar

                    08/08/2014  02:00 PM           863,688 spring-context-3.2.4.RELEASE.jar

                    08/08/2014  02:00 PM           869,674 spring-core-3.2.4.RELEASE.jar

                    08/08/2014  02:00 PM           196,807 spring-expression-3.2.4.RELEASE.jar

                    08/08/2014  02:00 PM           131,278 xbean-spring-3.14.jar

                                  19 File(s)      7,199,438 bytes

                                   2 Dir(s)  392,559,259,648 bytes free

                     

                    Here is my module.xml:

                     

                    <?xml version='1.0' encoding='UTF-8'?>

                    <module xmlns="urn:jboss:module:1.3" name="org.apache.activemq.ra">

                      <resource>

                        <resource-root path="."/>

                        <resource-root path="activemq-broker-5.9.0.jar"/>

                        <resource-root path="activemq-client-5.9.0.jar"/>

                        <resource-root path="activemq-jms-pool-5.9.0.jar"/>

                        <resource-root path="activemq-kahadb-store-5.9.0.jar"/>

                        <resource-root path="activemq-openwire-legacy-5.9.0.jar"/>

                        <resource-root path="activemq-pool-5.9.0.jar"/>

                        <resource-root path="activemq-protobuf-1.1.jar"/>

                        <resource-root path="activemq-ra-5.9.0.jar"/>

                        <resource-root path="activemq-spring-5.9.0.jar"/>

                        <resource-root path="aopalliance-1.0.jar"/>

                        <resource-root path="commons-net-3.3.jar"/>

                        <resource-root path="hawtbuf-1.9.jar"/>

                        <resource-root path="spring-aop-3.2.4.RELEASE.jar"/>

                        <resource-root path="spring-beans-3.2.4.RELEASE.jar"/>

                        <resource-root path="spring-context-3.2.4.RELEASE.jar"/>

                        <resource-root path="spring-core-3.2.4.RELEASE.jar"/>

                        <resource-root path="spring-expression-3.2.4.RELEASE.jar"/>

                        <resource-root path="xbean-spring-3.14.jar"/>

                      </resources>

                      <dependencies>

                        <module name="javax.api" slot="main"/>

                        <module name="javax.jms.api" slot="main"/>

                        <module name="javax.management.j2ee.api" slot="main"/>

                        <module name="javax.resource.api" slot="main"/>

                        <module name="org.apache.commons.logging"/>

                        <module name="org.apache.commons.pool"/>

                        <module name="org.apache.log4j"/>

                        <module name="org.slf4j"/>

                      </dependencies>

                    </module>

                     

                    And the relevant excerpt from my standalone:

                     

                            <subsystem xmlns="urn:jboss:domain:resource-adapters:2.0">

                                <resource-adapters>

                                    <resource-adapter id="activemq-rar.rar">

                                        <module slot="main" id="org.apache.activemq.ra"/>

                                        <transaction-support>NoTransaction</transaction-support>

                                        <config-property name="ServerUrl">tcp://activemq-server:61616/</config-property>

                                        <connection-definitions>

                                            <connection-definition class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory" jndi-name="java:/AMQConnectionFactory" enabled="true" use-java-context="true" pool-name="AMQConnectionFactory"/>

                                        </connection-definitions>

                                        <admin-objects>

                                            <admin-object class-name="org.apache.activemq.command.ActiveMQQueue" jndi-name="queue/Queue1" use-java-context="true" pool-name="queue-1">

                                                <config-property name="PhysicalName">Queue1Name</config-property>

                                            </admin-object>

                                            <admin-object class-name="org.apache.activemq.command.ActiveMQQueue" jndi-name="queue/Queue2" use-java-context="true" pool-name="queue-2">

                                                <config-property name="PhysicalName">Queue2Name</config-property>

                                            </admin-object>

                                        </admin-objects>

                                    </resource-adapter>

                                </resource-adapters>

                      </subsystem>

                     

                    I would just like to receive messages from ActiveMQ with MDBs. Unlike the original poster I do not want to have ActiveMQ take over as my messaging subsystem, I still want hornetq to manage internal messaging. The message printed by Wildfly:

                     

                    16:21:57,445 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 48) JBAS014613: Operation ("add") failed - address: ([

                        ("subsystem" => "resource-adapters"),

                        ("resource-adapter" => "activemq-rar.rar")

                    ]) - failure description: "JBAS010473: Failed to load module for RA [org.apache.activemq.ra]"

                     

                    is worthless to the point of being irritating. There has to be a better way to debug this, even if I did something trivially dumb.

                    • 7. Re: Wildfly 8.1 ActiveMQ Integration Issue
                      Frank Ecsedy Newbie

                      Found the issue. You DO in fact need the META-INF directory for the ra.xml file. The helpful answer turned out to be unhelpful in this instance.

                      • 8. Re: Wildfly 8.1 ActiveMQ Integration Issue
                        Alexey S. Newbie

                        Did everything that you suggested- doesnt work

                         

                        I got the exception

                        2014-10-19 12:11:16,548 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 49) JBAS014613: Operation ("add") failed - address: ([

                            ("subsystem" => "resource-adapters"),

                            ("resource-adapter" => "activemq-rar.rar")

                        ]) - failure description: "JBAS010473: Failed to load module for RA [org.apache.activemq]"

                        ActiveMQ is running, version of rar is 5.10.0. Nothing helps/
                        I have WildFly 8.1.0 final

                        • 9. Re: Re: Wildfly 8.1 ActiveMQ Integration Issue
                          dave7043 Newbie

                          I got the exception

                          2014-10-19 12:11:16,548 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 49) JBAS014613: Operation ("add") failed - address: ([

                              ("subsystem" => "resource-adapters"),

                              ("resource-adapter" => "activemq-rar.rar")

                          ]) - failure description: "JBAS010473: Failed to load module for RA [org.apache.activemq]"

                          ActiveMQ is running, version of rar is 5.10.0. Nothing helps/
                          I have WildFly 8.1.0 final

                           

                          There are a lot of possible reasons for that error; missing/corrupt META-INF/ra.xml), incorrect/invalid module.xml, etc...  There is actually a very informative error reason produced, but the controller logger is discarding it. 

                           

                          If you get the sources for the wildfly-connector module and debug break on lines 391 and 445 in org.jboss.as.connector.subsystems.resourceadapters.RaOperationUtil#installRaServicesAndDeployFromModule

                          throw new OperationFailedException(MESSAGES.failedToLoadModuleRA(moduleName), e);
                          
                          

                           

                          The source exception (e) will have the true cause of the problem.

                          • 10. Re: Wildfly 8.1 ActiveMQ Integration Issue
                            mazz Master

                            FWIW: I believe I have a simple mvn module that builds this ra extension module properly (Heiko R. has been using this successfully).

                             

                            See: https://github.com/rhq-project/rhq-msg/tree/master/rhq-msg-ra-wf-module

                             

                            Its currently building with ActiveMQ 5.10.0

                            • 11. Re: Wildfly 8.1 ActiveMQ Integration Issue
                              George Gastaldi Master

                              Thank you, this solved another problem that was haunting me for years!