0 Replies Latest reply on Aug 8, 2014 4:40 PM by Kumar Gautam

    Unable to create JAXBContext: 1 counts of IllegalAnnotationExceptions no-arg default constructor

    Kumar Gautam Newbie

      Hi I have 2 JBOSS instances on 2 different servers .

      In both the Jboss instance i am deploying a same WAR File .

      I am calling a web services from my WAR . In one of the server i am getting below error while in other server it is running fine.

       

      The error in the server is resulting in shutting down the JBoss Instance in that server.

       

      Unable to create JAXBContext: 1 counts of IllegalAnnotationExceptions

      01:07:12,479 ERROR [stderr] com.sun.xml.bind.v2.runtime.IllegalAnnotationsException: 1 counts of IllegalAnnotationExceptions

      01:07:12,479 ERROR [stderr]  java.lang.StackTraceElement does not have a no-arg default constructor.

      01:07:12,481 ERROR [stderr]  at com.sun.xml.bind.v2.runtime.IllegalAnnotationsException$Builder.check(IllegalAnnotationsException.java:102)
      01:07:12,481 ERROR [stderr]  at com.sun.xml.bind.v2.runtime.JAXBContextImpl.getTypeInfoSet(JAXBContextImpl.java:438)
      01:07:12,481 ERROR [stderr]  at com.sun.xml.bind.v2.runtime.JAXBContextImpl.<init>(JAXBContextImpl.java:286)
      01:07:12,482 ERROR [stderr]  at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:139)
      01:07:12,482 ERROR [stderr]  at com.sun.xml.bind.v2.ContextFactory.createContext(ContextFactory.java:117)
      01:07:12,482 ERROR [stderr]  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      01:07:12,482 ERROR [stderr]  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      01:07:12,483 ERROR [stderr]  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      01:07:12,483 ERROR [stderr]  at java.lang.reflect.Method.invoke(Method.java:606)
      01:07:12,483 ERROR [stderr]  at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:211)
      01:07:12,484 ERROR [stderr]  at javax.xml.bind.ContextFinder.find(ContextFinder.java:392)
      01:07:12,484 ERROR [stderr]  at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:618)
      01:07:12,484 ERROR [stderr]  at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:565)

       

      I have also tried to copy the instance of JBoss Server from working instance  to other server but still it gives same error .

       

      JBoss Version : JBoss EAP 6.1.0

       

      Require help for resolving this issue !!!!!!!