2 Replies Latest reply on Aug 12, 2014 8:39 AM by shruthi b

    jboss as7 deployment issue

    shruthi b Newbie

      Hi All

       

      I have developed a dynamic web project with java servlets. I am using Jboss AS 7.1.1 as the app server. The application executes fine in the tomcat server. However, when I execute it with jboss..I am getting a 404 error message telling "The requested resource is not available".

      My web.xml has the servlet mapping as follows:

      <servlet>

               <description>Item Maintenance</description>

               <display-name>ItemMaintenance</display-name>

               <servlet-name>ItemMaintenance</servlet-name>

               <servlet-class>com.sample.extjs.action.ItemMaintenance</servlet-class>

      </servlet>

        <servlet-mapping>

               <servlet-name>ItemMaintenance</servlet-name>

               <url-pattern>/ItemMaintenance</url-pattern>

        </servlet-mapping>

       

      I also tried changing the url-pattern to /* but It does not work.

      Can someone help me in resolving this issue...?

       

      Thanks in advance

        • 1. Re: jboss as7 deployment issue
          Lalit Shaktawat Newbie

          Hi Shrithi

           

          If you want to run JBoss AS with Apache ( HTTP ) server. Then only it's possible. Just change your configuration of http.conf file.

           

          Your JBoss is running on port number : 8080. But you want in 80. So you have to configure it with apache. With tomcat it will not create any issue, Because tomcat is also working with port number 8080. It will be create an issue with JBoss. So better to use to connect JBoss with apcahe. That time your problem will definitely resolved.

           

          Use : mod_jk with worker.properties or mod proxy, mod cluster method to connect and load balancing.

           

          If you need more help. Tell me your motive. Accordingly I will send a configuration.

           

          Thanks.

          • 2. Re: jboss as7 deployment issue
            shruthi b Newbie

            Hi Lalit

             

            Thanks for your reply.. I understood your point..However, there is no http.conf file in my Jboss directory. Should I install anything other than Jboss AS 7.1.1 for it to work?

            Right now, I am just trying to execute a simple servlet example in the Eclipse IDE using the Jboss server.

             

            Thanks in advance