0 Replies Latest reply on Aug 14, 2014 6:19 AM by Javier Perez

    Problem building kie-wb-distributions-6.1.0.Final

    Javier Perez Newbie

      Hi everybody,


      I've downloaded Kie drools workbench (6.1.0 final version) from http://repository.jboss.org/nexus/content/groups/public/org/kie/kie-drools-wb-distribution-wars/6.1.0.Final/kie-drools-w… , I've deployed the .war file in JBoss and I've tested the application, I've also realized the same operation with Tomcat (http://repository.jboss.org/nexus/content/groups/public/org/kie/kie-drools-wb-distribution-wars/6.1.0.Final/kie-drools-w…) and I've also tested the application without problems.


      But the problem is when I build .war files from source code and I deploy these .war in JBoss or Tomcat, I login in the web application but when message "Please wait, loading application..." is shown, it never continues and the image of the left side (a loading image) isn't never shown.


      I've observed that .war file downloaded from repository.jboss.org has a size of 164 or 166 MegaBytes depending of JBoss or Tomcat version, but the .war built from source code (kie-drools-wb-6.1.0.Final-jboss-as7.0.war or kie-drools-wb-6.1.0.Final-tomcat7.0.war) has between 88 and 91 MB depending of the version, it is not normal the size is so small. I've downloaded source code from Release 6.1.0.Final · droolsjbpm/kie-wb-distributions · GitHub, I make the build from Linux because I've had problems with Windows related with classpath length. When I import the Project in Eclipse I see there are over 300 folders in Project Explorer and I make Run As -> Maven build in the "kie-wb-distributions-6.1.0.Final" folder.


      Please, has anyone tried to build this application from source code and has had the same problem with .war files size?, does somebody know how to solve this problem?.


      I haven't removed any element of the Project, I download the source code, open Project in Eclipse, some errors were shown but I could solve it except three (But these errors aren't a problem to build successfully):

      Can not find the tag library descriptor for http://jakarta.apache.org/taglibs/i18n-1.0 in /kie-wb-webapp/src/main/webapp/login.jsp

      Can not find the tag library descriptor for http://jakarta.apache.org/taglibs/i18n-1.0 in /kie-wb-webapp/src/main/webapp/not_authorized.jsp

      Referenced file contains errors (http://docs.jboss.org/cdi/beans_1_0.xsd) in /kie-wb-webapp/src/main/webapp/WEB-INF/beans.XML

      And finally I Run As -> Maven build and I get the message "Build Success".


      Thank you and regards.