4 Replies Latest reply on Aug 15, 2014 11:17 AM by David de Lucca

    My log is not working

    David de Lucca Newbie

      Hello folks!

       

      I have a jar file inside the war file that contains a log4j.properties inside META-INF ( already have tried to put one level above META-INF ):

       

      # Root logger option
      log4j.rootLogger=INFO, file
      
      # Direct log messages to a log file
      log4j.appender.file=org.apache.log4j.RollingFileAppender
      
      #Redirect to Tomcat logs folder
      #log4j.appender.file.File=${catalina.home}/logs/logging.log
      
      log4j.appender.file.File=c:\\export\\logs\mylog.log
      log4j.appender.file.MaxFileSize=10MB
      log4j.appender.file.MaxBackupIndex=10
      log4j.appender.file.layout=org.apache.log4j.PatternLayout
      log4j.appender.file.layout.ConversionPattern=%d{yyyy-MM-dd HH:mm:ss} %-5p %c{1}:%L - %m%n
      

       

      When i run maven to compile my projects, it runs unit tests and the log messages goes to file "mylog.log" but when i deploy on Wildfly 8.0 and try to log something, it only logs on server.log.

       

      I'm missing some configuration but i couldn't figure what is missing.

       

      I have read the documentation and added the tag <use-deployment-logging-config value="false"/> to standalone.xml but still not working. I already have tried to put the log4j.properties inside the war file but still not working.

       

      Anyone could give me a hand to make my log works?

       

      Thank in advance.