3 Replies Latest reply on Jan 3, 2008 8:00 AM by Mike Mc Elligott

    Cannot run demo - problem with maven jbi

    Mike Mc Elligott Newbie

      I just downloaded FUSE today and installed the latest version of maven (which I never used before). When I try and run the demo I get

       

      mvn install jbi:projectDeploy

       

      Scanning for projects...

      Searching repository for plugin with prefix: 'jbi'.

      -


      BUILD ERROR

      -


      The plugin 'org.apache.maven.plugins:maven-jbi-plugin' does not exist or

      no valid version could be found

      -


      For more information, run Maven with the -e switch

      -


      Total time: < 1 second

      Finished at: Thu Dec 20 16:15:40 GMT 2007

      Final Memory: 1M/4M

      -


       

       

      I have tried and searched everything I could think of but no luck - it is obviously some really basic error since.

       

      I tried running maven install and maven dependency:go-offline to make sure I had all latest plugins. I looked in the maven plugins directory to see if the jbi one was in there. The directory was there and inside was a file called maven-metadata-central.xml but that was all. Google gave me a link http://servicemix.apache.org/maven-1x-jbi-plugin.html where I actually downloaded the plugin jar and dropped into the jbi plugin directory of maven. Still no joy

       

      Any help for a newbie?

       

      Cheers

      Mike