2 Replies Latest reply on Jan 21, 2008 6:12 PM by Bruce Snyder

    Access denied to the org.eclipse.jst.j2ee jar

    Christopher Hunt Newbie

      Hi there,

       

      I've installed the latest Fuse ESB (3.3.0.6) and followed the instructions exactly as per http://open.iona.com/wiki/display/ProdInfo/FUSEEclipseTools for my Mac OS X Leopard based Eclipse Europa distro.

       

      I then tried File->New->Other->Java Business Integration Service Units->JMS Provider (I want to create a socket server for some proprietary protocol that then emits messages on to the ESB). All is well from a Maven pespective, and then I get the known issue of the "J2EEComponentMappingUpdateJob" error.

       

      I've tried downloading the http://open.iona.com/issues/secure/attachment/10031/org.eclipse.jst.j2ee_1.1.103.v200706121630.jar and then received an ACCESS DENIED response. I am logged into the forums. What gives? Additionally if I try to look at the ESB-14 issue then I get the same access denial.

       

      Given the access denials I then updated the JST plugins via the "manage config" functionality of Eclipse, created another JBI JMS provider project and still had the problem.

       

      Help!

       

      Cheers,

      -C