3 Replies Latest reply on Feb 21, 2008 2:06 PM by Bruce Snyder

    Problem with Maven2 - Requested download does not exist.

    Marian Mroz Newbie

      I have a little problem with create Java Business Integration Service Units. Every time I see the same communicate:

       

      //////////////////////

      Scanning for projects...

      Searching repository for plugin with prefix: 'archetype'.

      org.apache.maven.plugins: checking for updates from central

      org.codehaus.mojo: checking for updates from central

      artifact org.apache.maven.plugins:maven-archetype-plugin: checking for updates from central

      -


      Building Maven Default Project

          task-segment: archetype:create (aggregator-style)

      -


      Preparing archetype:create

      No goals needed for project - skipping

      Unable to get resource from repository central (http://repo1.maven.org/maven2)

      Setting property: classpath.resource.loader.class => 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.

      Setting property: velocimacro.messages.on => 'false'.

      Setting property: resource.loader => 'classpath'.

      Setting property: resource.manager.logwhenfound => 'false'.

      archetype:create

      No archetype repository found.

      org.apache.maven.archetype.downloader.DownloadNotFoundException: Requested download does not exist.

      at org.apache.maven.archetype.downloader.DefaultDownloader.download(DefaultDownloader.java:62)

      at org.apache.maven.archetype.common.DefaultArchetypeArtifactManager.exists(DefaultArchetypeArtifactManager.java:298)

      at org.apache.maven.archetype.ui.DefaultArchetypeGenerationConfigurator.configureArchetype(DefaultArchetypeGenerationConfigurator.java:102)

      at org.apache.maven.archetype.mojos.CreateProjectFromArchetypeMojo.execute(CreateProjectFromArchetypeMojo.java:167)

      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:412)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:534)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:488)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:458)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:306)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:219)

      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:140)

      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:361)

      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:150)

      at org.apache.maven.embedder.MavenEmbedder.execute(MavenEmbedder.java:690)

      at org.maven.ide.eclipse.Maven2Executor.main(Maven2Executor.java:112)

      Caused by: org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable to download the artifact from any repository

      Try downloading the file manually from the project website.

      Then, install it using the command:

          mvn install:install-file -DgroupId=org.apache.servicemix.tooling -DartifactId=servicemix-http-consumer-service-unit \

              -Dversion=fuse-3.2.0.1 -Dpackaging=jar -Dfile=/path/to/file

        org.apache.servicemix.tooling:servicemix-http-consumer-service-unit:jar:fuse-3.2.0.1

      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:136)

      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveAlways(DefaultArtifactResolver.java:69)

       

      Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable to download the artifact from any repository

      at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:265)

      at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:124)

       

      mojo-execute : archetype:create

      Diagnosis: The desired archetype does not exist (org.apache.servicemix.tooling:servicemix-http-consumer-service-unit:fuse-3.2.0.1)

      FATAL ERROR: Error executing Maven for a project

      project-execute : org.apache.maven:super-pom:jar:2.0 (  task-segment: archetype:create (aggregator-style) )

      Diagnosis: The desired archetype does not exist (org.apache.servicemix.tooling:servicemix-http-consumer-service-unit:fuse-3.2.0.1)

      FATAL ERROR: Error executing Maven for a project

      -


      BUILD SUCCESSFUL

      -


      Total time: 3 second

      Finished at: Mon Feb 18 16:45:46 CET 2008

      Memory 0M/12M

      -


      Error for project: Maven Default Project (during archetype:create)

      -


      The desired archetype does not exist (org.apache.servicemix.tooling:servicemix-http-consumer-service-unit:fuse-3.2.0.1)

       

      -


      Trace The desired archetype does not exist (org.apache.servicemix.tooling:servicemix-http-consumer-service-unit:fuse-3.2.0.1)

      -


      reactor-execute : C:\ESB\EclipseFeb2008\workspace\11111111

      FATAL ERROR: Error executing Maven for a project

      BUILD ERRORS

      -


      Total time: 6 seconds

      Finished at: Mon Feb 18 16:45:46 CET 2008

      Final Memory: 8M/15M

      -


      org.apache.maven.reactor.MavenExecutionException: Some builds failed

      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:210)

      at org.apache.maven.embedder.MavenEmbedder.execute(MavenEmbedder.java:690)

      at org.maven.ide.eclipse.Maven2Executor.main(Maven2Executor.java:112)

       

      //////////////////////

       

      Two months ago I didn't have a problem with creating service units, everything worked good - there wasn't problem with use it

       

      Do you any idea what is wrong with this?