1 Reply Latest reply on Apr 3, 2008 2:40 AM by Bruce Snyder

    Lets change the default transport protocol used in ServiceMix'

    Torsten Mielke Apprentice

      Currently ServiceMix configures the underlying ActiveMQ to simply use tcp as the transport protocol. This is defined in conf/servicemix.properties:

       

      activemq.url               = tcp://${activemq.host}:${activemq.port}

       

      While this configuration works fine and is sufficient for using ServiceMix in development, it will not recover from any network failures and is therefore not suitable for running in a production system. In case of a network failure or inactivity timeout, ActiveMQ will simply raise an exception but won't try to reconnect. You will need to restart ServiceMix in order to recover from such error. For reconnection to happen, the failover protocol should be used. Hence the default configuration should be changed to

       

      activemq.url               = failover://(tcp://${activemq.host}:${activemq.port})

       

      Failover should be the default protocol and enabled out of the box. This is captured in  ESB-166.