2 Replies Latest reply on Sep 16, 2008 5:38 AM by Gert Vanthienen

    Maven error creating a Validation Service Unit

    Miere L. Teixeira Newbie

      Hi Friends!

       

      Im new to Fuse/Servicemix. We're playing with him about 2 weeks. Im trying to create a validation service unit as show  here. I've changed the maven creation command line adding the iona repository as it is at smx-arch file (at bin directory). But it seems to not found the jar file at iona's repository.

       

      Bellow you can see the error lines from my console stdout:

       

      Scanning for projects...

      Reactor build order:

         Hengst

         Hengst:SU:FileSystem

         Hengst:SU:EIP

         Hengst:SA

      Searching repository for plugin with prefix: 'archetype'.

      -


      Building Hengst

          task-segment: archetype:create (aggregator-style)

      -


      Setting property: classpath.resource.loader.class => 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.

      Setting property: velocimacro.messages.on => 'false'.

      Setting property: resource.loader => 'classpath'.

      Setting property: resource.manager.logwhenfound => 'false'.

      archetype:create

      This goal is deprecated. Please use mvn archetype:generate instead

      Defaulting package to group ID: ecm.integration.hengst

      We are using command line specified remote repositories: http://repo.open.iona.com/maven2

      Downloading: http://repo.open.iona.com/maven2/org/apache/servicemix/tooling/servicemix-validation-service-unit/3.3.1.6-fuse/servicemix-validation-service-unit-3.3.1.6-fuse.jar

      -


      BUILD ERROR

      -


      Error creating from archetype

       

      Embedded error: OldArchetype does not exist.

      Unable to download the artifact from any repository

      -


      For more information, run Maven with the -e switch

      -


      Total time: 5 seconds

      Finished at: Mon Sep 15 09:47:24 BRT 2008

      Final Memory: 10M/18M

      -


       

      I've tryied to access the above URL but the Browser got a 404 error from server, so the file doesn't exists. I want to know if I did something wrong, or it is a Bug?

       

      PS: Sorry about my poor english.