4 Replies Latest reply on Aug 13, 2004 6:30 PM by vishp

    DeploymentException: Couldn't create entity command: ; - nes

    vishp Newbie

      Hello,

      I am using Oracle 8 and jboss 3.2.5. I build and deployed the sample roster application and expected it to create the tables like PlayerEJB, etc. But it jboss window shows the following error:

      14:03:54,721 INFO [EJBDeployer] Deployed: file:/C:/jboss-3.2.5/server/default/tmp/deploy/tmp34753RosterApp.ear-contents/roster-ejb.jar
      14:04:01,050 ERROR [EntityContainer] Starting failed jboss.j2ee:jndiName=local/LeagueEJB,service=EJB
      org.jboss.deployment.DeploymentException: Couldn't create entity command: ; - nested throwable: (java.lang.NullPointerException)
      at org.jboss.ejb.plugins.cmp.jdbc.JDBCCommandFactory.createCreateEntityC
      ommand(JDBCCommandFactory.java:159)
      at org.jboss.ejb.plugins.cmp.jdbc.JDBCStoreManager.startStoreManager(JDB
      CStoreManager.java:474)

      I have copied the oracle classes12.zip to the lib folder, then changed the
      oracle-ds.xml file to contain
      <local-tx-datasource>
      <jndi-name>OracleDS</jndi-name>
      <connection-url>jdbc:oracle:thin:@myhost:1521:cwintl</connection-url>
      <driver-class>oracle.jdbc.driver.OracleDriver</driver-class>
      <user-name>user</user-name>
      pwd...


      Also changed standardjbosscmp-jdbc.xml as follows:

      java:/OracleDS
      <datasource-mapping>Oracle8</datasource-mapping>


      Can you see any obvious problems? Please help.


      Thanks,

        • 1. Re: DeploymentException: Couldn't create entity command: ; -
          vishp Newbie

          Actually, I checked and realized that I had left out some default settings from standardjbosscmp.xml. Added <create-table> and other tags and then the tables teamejb, playerejb got created. But now I get following error

          Starting failed jboss.j2ee:jndiName=local/LeagueEJB,service=EJB
          org.jboss.deployment.DeploymentException: Error compiling EJB-QL statement 'select distinct object(p) from Player p
          where p.salary between ?1 and ?2'; - nested throwable: (org.jboss.ejb.plugins.cmp.ejbql.ParseException: Encountered "where" at line 2, column 1. Was expecting one of:

          "," ...
          )
          at org.jboss.ejb.plugins.cmp.jdbc.JDBCEJBQLQuery.(JDBCEJBQLQuery.java:52)

          This is probably preventing schema creation for leagueejb.

          • 2. Re: DeploymentException: Couldn't create entity command: ; -
            Alexey Loubyansky Master

            This is a bug that was fixed in 3.2.6. Just put WHERE on the same line 1, i.e. no new lines in the query.

            • 3. Re: DeploymentException: Couldn't create entity command: ; -
              vishp Newbie

              Thanks Alexey. I made changes as you suggested and it worked.
              However I could not find a bug record at sourceforge on that problem. I did find bugs 874163 and 828845 but these do not seem related to the problem. Do you by any chance know the bug record, or want me to file a bug for the earlier problem (I have not tried 3.2.6 yet).

              Also now I am getting the following error :

              WARN [ServiceController] Problem starting service jboss.j2ee:jndiName=local/LeagueEJB,service=EJBRuntimeErrorException: java.lang.NoSuchMethodError Cause: java.lang.NoSuchMethodError at org.jboss.mx.server.ReflectedDispatcher.handleInvocationExceptions(ReflectedDispatcher.java:99)

              Possibly this is some simple problem and I will try to look into the code - but please let me know if you know offhand the cause and/or solution.

              Again, appreciate the help.


              - Vish.

              • 4. Re: DeploymentException: Couldn't create entity command: ; -
                vishp Newbie

                With a different search, was able to find the bug 984976 for the earlier EJB-QL problem.

                - Vish.