7 Replies Latest reply on Oct 16, 2008 1:18 AM by Dinesh Reddy

    Exceptions observed while running an eip

    Dinesh Reddy Newbie

      Hi,

       

      I have installed the FUSE Integration Designer by following the steps given in the install guide. I have tried creating the an EIP Diagram and run it using the Run configuration.

       

      But, I am not able to run the EIP. I am getting an exception in the console view. Can any body tell me where I am doing the wrong? I have attached the EIP file and the exception trace.

       

      Thanks

      Regards,

      Dinesh

        • 1. Re: Exceptions observed while running an eip
          Oisin Hurley Novice

          Hi Dinesh

          The console view tells me that there is a problem a generated Camel Spring configuration.

           

          I took a clean Eclipse 3.3.2 install, updated it using the instructions, created a project, imported the .eip file you provided. I didn't see any exceptions

           

          What I am thinking is that you may have a version of the Camel Spring configuration schema file that doesn't validate the id attribute on Camel processors. Earlier versions of Camel didn't allow this attribute. Just so that I can check, can you send me some platform information?

           

          In your IDE, do Eclipse > About Eclipse Platform then press Configuration Details. This will give a big list of your configuration. Check the versions of

          the Camel-specific plugins - they should look something like the following (some details have been removed):

           

          com.iona.eitools.camel (1.4.2.0) 
          com.iona.eitools.camel.exporter (1.0.0.200809221551)
          com.iona.eitools.camel.importer (1.0.0.200809221551) 
          com.iona.eitools.camel.importer.ui (1.0.0.200809221551)
          com.iona.eitools.camel.prefs.bean.configs (1.0.0) 
          

           

          If you like, attach the whole configuration to the next forum entry and I will be able to compare it to my set-up here.

          • 2. Re: Exceptions observed while running an eip
            Dinesh Reddy Newbie

            Hi oisin,

             

            Thanks for your reply.

             

            I have checked the configuration and plug-ins versions. I compared the list of plug-ins you mentioned in your reply, with my plug-ins. I observed that I have the latest one that you. So I just removed the latest plug-ins and put the same version of plug-ins as you have. But still I see the same error.

             

            I have attached the complete eclipse configuration to this thread.

             

            Thanks in advance,

            Dinesh

            • 3. Re: Exceptions observed while running an eip
              Oisin Hurley Novice

              Nothing jumps out at me from the config, Dinesh. Two things to try next:

               

              1. Bring up your Eclipse preferences and choose Web and XML > XML Catalog. Under the Plugin Specified Entries twisty, you will see some Camel-specific namespaces. The one you should see is

               

              http://activemq.apache.org/camel/schema/spring/camel-spring-1.4.0.xsd
              

               

               

              2. Let's see if the issue is to do with your specific project (where it could be a project metadata issue), or if the same thing occurs when you re-create the situation in a new project. What I did was to put the .eip file into a General project, then double-click on it to open the diagram. Then, in the diagram editor, I did a right-click and selected Export To Camel...

               

              Oh, and it would be useful to attach the Camel xml file that gets generated too!

              • 4. Re: Exceptions observed while running an eip
                Dinesh Reddy Newbie

                Hi,

                 

                Sorry for delayed reply. I have checked for the schema in the preferences and found it right. And I tried the run by putting the eip and camel configurations in the simple project. But it again bombed. I have attached the camel configuration file.

                 

                Thanks

                Regards,

                Dinesh

                • 5. Re: Exceptions observed while running an eip
                  Claus Ibsen Master

                  There problem could be that in XML you can not use & as parameter seprations in the URI of your endpoints.

                   

                  You have to HTML escape it so & should be &

                   

                  So this line:

                  "file:///C:/temp/Sample1.xml?autoCreate=false&delete=true

                   

                  Should be:

                  "file:///C:/temp/Sample1.xml?autoCreate=false&delete=true

                  • 7. Re: Exceptions observed while running an eip
                    Dinesh Reddy Newbie

                    Hi,

                     

                    Finally I could resolve the problem. Why I was getting the problem is, I was adding an old spring jar in the classpath of the Run configuration. That jar contains an old schema. Now I changed the classpath entry and everything works fine.

                     

                    Thanks so much for your support.

                     

                    Thanks

                    Regards

                    Dinesh