3 Replies Latest reply on Jan 19, 2009 6:52 AM by Surajit Choudhury

    Problem with running the Getting Started Demo

    Surajit Choudhury Newbie

      Hi, I am trying to run the Getting Started screencast demo posted by Adrian Trenaman at http://fusesource.com/resources/video-archived-webinars/ but have run into problems with plugins. If I install both the Fuse Eclipse Tools and the Maven plugins, my context menu on a Maven Project has only a few items - missing add new Maven Module. If I remove the Fuse Eclipse Tools plugin, then when a service unit is selected for creation from an archetype, it complains that the desired archetype does not exist.

      I thought I read somewhere that there were problems with these plugins coexisting but can't find the ref - if so, what plugins does that demo require?

      Thanks in advance.

        • 1. Re: Problem with running the Getting Started Demo
          Oisin Hurley Novice

          The video demonstrations from Adrian are using a version of Eclipse without the tools installed, but with the latest version of

          m2eclipse

          installed. If you take a fresh copy of Eclipse 3.4.1, and install the latest versions of

          m2eclipse

          , then you should be able to follow the videos.

           

          --oh

          • 2. Re: Problem with running the Getting Started Demo
            Surajit Choudhury Newbie

            Thanks Oisin. I installed Eclipse 3.4.1 and the Maven plugin, but I got the same response as last time:

            1/16/09 3:29:00 PM IST: The desired archetype does not exist (org.apache.servicemix.tooling:servicemix-file-poller-service-unit:3.3.1.12-fuse) The desired archetype does not exist (org.apache.servicemix.tooling:servicemix-file-poller-service-unit:3.3.1.12-fuse)

            When you say latest version of m2eclipse, I suppose it is still from http://m2eclipse.sonatype.org/update/ (also tried the dev version - same results) and not the Q4E or Eclipse IAM. (I tried but could not install those plugins)

             

            This problem was also reported in the thread - http://fusesource.com/forums/thread.jspa?messageID=1532 - but there was no answer as how to fix it for using Eclipse.

             

            Edited by: surajit on Jan 16, 2009 7:37 AM

            • 3. Re: Problem with running the Getting Started Demo
              Surajit Choudhury Newbie

              It appears that using Maven version 2.0.8 gets around this problem, but the problem that appears next is that the service assembly module cannot be created from its archetype. The error reported is:

               

              1/19/09 4:47:37 PM IST: org.apache.servicemix.maven.plugin.jbi.GenerateServiceAssemblyDescriptorMojo#execute() caused a linkage error (java.lang.NoSuchMethodError). Check the realms:

               

              NOTE:

              Plugin realm is: /plugins/org.apache.servicemix.tooling:jbi-maven-plugin:3.2.3@48/thread:Worker-14

              Container realm is: plexus.core

              ...(a bunch of 61 urls pointing to jars in APP_DIR/.m2/repository)...

              Realm ID: /projects/com.ventyx.ps:file-to-jms-sa:0.0.1-SNAPSHOT/thread:Worker-14

               

               

              Realm ID: plexus.core

               

               

              org.apache.maven.artifact.resolver.ArtifactResolutionResult.setArtifactResolutionNodes(Ljava/util/Set;)V

               

               

              Any ideas what's missing? Thanks.