3 Replies Latest reply on Apr 29, 2009 2:17 PM by lorinda visnick

    Can't build fuse msg bkr; Can't build project with dependency either

    Marc Breslow Newbie

      Is activemq-protobuf really required for 5.3?  There's a dependency in the activemq-core pom on it but it seems like it may have been renamed to activemq-protocol-buffers.  I can't build a project of mine if I add activemq-core 5.3.0.0-fuse as a maven dependency because it fails to find the activemq-protobuf 1.0-SNAPSHOT version.

       

      I also downloaded the fuse 5.3 source code and tried to compile with maven.  It too fails to build:

       

      -


      BUILD ERROR

      -


      Error building POM (may not be this project's POM).

       

       

      Project ID: org.apache.activemq.protobuf:activemq-protobuf

       

      Reason: POM 'org.apache.activemq.protobuf:activemq-protobuf' not found in repository: Unable to download the artifact from any repository

       

        org.apache.activemq.protobuf:activemq-protobuf:pom:1.0-SNAPSHOT

       

      from the specified remote repositories:

        apache.snapshots (http://people.apache.org/repo/m2-snapshot-repository/),

        central (http://repo1.maven.org/maven2)

      for project org.apache.activemq.protobuf:activemq-protobuf