1 Reply Latest reply on Jul 15, 2009 12:44 PM by Vincent Girard-Reydet

    [ESB4] Help on BC + SE setup

    Vincent Girard-Reydet Newbie

      Hi,

       

      I'm trying to reproduce the cxf-wsdl-first-osgi-package sample and I run into problems when starting the BC. I get the following error :

       

      17:52:28,013 | INFO  | xtenderThread-91 | DefaultListableBeanFactory       | pport.DefaultListableBeanFactory  414 | Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@5fdb25: defining beans ; root of factory hierarchy

      17:52:28,013 | WARN  | xtenderThread-91 | CustomListenerAdapterUtils       | apter.CustomListenerAdapterUtils  161 | Custom method threw exception when passing service type

      javax.jbi.management.DeploymentException: java.lang.NullPointerException

           at org.apache.servicemix.cxfbc.CxfBcConsumer.validate(CxfBcConsumer.java:523)

           at org.apache.servicemix.common.osgi.EndpointTracker$OsgiServiceUnit.(EndpointTracker.java:77)

           at org.apache.servicemix.common.osgi.EndpointTracker.register(EndpointTracker.java:58)

           at sun.reflect.GeneratedMethodAccessor106.invoke(Unknown Source)

           at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

           at java.lang.reflect.Method.invoke(Method.java:597)

       

       

      However when installing & launching the example everything goes well.

       

      From my perspective everything seems fine, I have tried to mimick it as much as possible. It seems however that the BC does not find the endpoint. Anyone has an idea ?

       

      Note: the soap-connector is the BC, the resource-finder is the SE.

      Note 2: my project depends on an externalized API (not included here) that was generated from the wsdl that is included in the archives.