3 Replies Latest reply on Aug 13, 2009 11:31 AM by Robert Yetman

    camel version mismatch FID - FuseESB 3.4.0.3

    Robert Yetman Newbie

      I'm trying to deploy an EIP project from FID 1.2.1 to FuseESB 3.4.0.3, and one of the components in it is a camel bean.  I've created the Spring bean file, and the Java POJO class.  When I deploy it,  I get many "Could not find class" WARNINGs for classes in:

       

      org/apache/camel/scala

      org/apache/camel/componnt/jhc

      org/apache/camel/component/mail

      org/apache/camel/component/mina

       

      Then I get

      java.lang.NoClassDefFoundError: org/apache/cxf/message/MessageContentsList

      java.lang.NoClassDefFoundError: ca/uhn/lh7v2/parser/Parser

      java.lang.NoClassDefFoundError: org/springframework/integration/message/Message

       

      and so on...

       

      I suspect at least part of the problem is because FID 1.2.1 ships with Camel 1.5.0 and  FuseESB 3.4.0.3 ships with Camel 1.6.1.   But that only explains the warnings, not the NoClassDefFoundErrors I'm getting.

       

      So how do I fix this?   I could drop the apache-camel-1.5.0.jar into the FuseESB lib dir, but I'm worried about having the multiple versions in my

      classpath.