4 Replies Latest reply on Sep 8, 2009 6:50 AM by Robert Yetman

    FID and Fuse 3.3.1.20 - Compatible?

    Robert Yetman Newbie

      Are the assemblies generated by FID 1.2.1 deployable on FuseESB 3.3.1.20?  Reason I ask is I have an EIP diagram that is a very basic  file -> bean -> file.

      However, when I deploy it into my server I get a

      java.lang.NOClassDefFoundError: org/springframework/beans/factory/support/GenericBeanDefinition

       

      error message.   Some searching finds this class in spring-beans-2.5.6.jar

      but NOT in spring-beans-2.0.8.jar (version used by FuseESB 3.3.1.20).

       

      This same assembly deployed correctly into FuseESB 3.4.0.3.