3 Replies Latest reply on Nov 16, 2009 6:17 PM by mat dav

    Fuse ESB 4.1.0.2

    mat dav Newbie

      Hi,

       

      I tried to deploy  an example to read email using an OSGI bundle, defined an endpoint using Java DSL to read the mail.

       

      When deployed, it thows an error "endpoint not found, check for component jar in the classpath ".

       

      As as was searching the fourm, I got some tips, to add new features to ESB , to get it working.  I tried adding the camel-email component, but the same error.

       

      Any tips as to how to resolve the error.I shall throw the error stack in the next mail.

       

      Is there any article that shows how to work with camel-components with ESB .

       

      Iam new to camel-components and ESB, tips appreciated.

       

      Cheers

      Dav

        • 1. Re: Fuse ESB 4.1.0.2
          Willem Jiang Master

          Did you use the features:install camel-mail to install the camel-mail and it related java mail bundle ?

          • 2. Re: Fuse ESB 4.1.0.2
            mat dav Newbie

            Thanks for the reply.

             

            I installed the features using the addUrl command and installed the camel-mail., it worked against exchange mail.

             

            addUrl http://repo.fusesource.com/maven2/org/apache/servicemix/camel/org.apache.servicemix.camel.features/4.0.1.2-fuse/org.apache.servicemix.camel.features-4.0.1.2-fuse-features.xml

             

            then

            features install camel-mail

             

            I have another issue, the pop3 / imap protocol is although reading attatchments , the  hasattatchment() method  returns false in a processor method.

             

            But the email is moved to a different folder with attachment.

             

            Any tips guys.

             

            Cheers

            dav

             

            Edited by: mdav on Nov 9, 2009 10:35 PM

             

            Edited by: mdav on Nov 9, 2009 10:39 PM

            • 3. Re: Fuse ESB 4.1.0.2 and camel - mail
              mat dav Newbie

              Hi  Guys,

               

              I get this error when I use imap to read exchange emails :

               

              | WARN  | Component@3d0611 | ScheduledPollConsumer            | camel.impl.ScheduledPollConsumer   68 | An exception occured while polling: Endpoint[imap://mdav@hostname?password=password&processOnlyUnseenMessages=true&consumer.delay=30000]: Unexpected error on server stream (java.net.SocketException: Connection reset)

              javax.mail.MessagingException: Unexpected error on server stream (java.net.SocketException: Connection reset)

                   at org.apache.geronimo.javamail.store.imap.connection.IMAPResponseStream.nextByte(IMAPResponseStream.java:386)

              at org.apache.geronimo.javamail.store.imap.connection.IMAPResponseStream.readBuffer(IMAPResponseStream.java:290)

                   at org.apache.geronimo.javamail.store.imap.connection.IMAPResponseStream.readData(IMAPResponseStream.java:274)

                   at org.apache.geronimo.javamail.store.imap.connection.IMAPResponseStream.readResponse(IMAPResponseStream.java:94)

                   at org.apache.geronimo.javamail.store.imap.connection.IMAPConnection.receiveResponse(IMAPConnection.java:396)

                   at org.apache.geronimo.javamail.store.imap.connection.IMAPConnection.sendCommand(IMAPConnection.java:324)

                   ...

              ..

              ..Caused by: java.net.SocketException: Connection reset

                   at java.net.SocketInputStream.read(SocketInputStream.java:168)

                   at java.net.SocketInputStream.read(SocketInputStream.java:182)

               

              Iam using Fuse ESB 4.1.102 and Camel-mail.

               

              The same code was working fine 1 day back and then I restarted the machine, then it gives the above error.

               

              From my router class :

               

              from("imap://mdav@hostname?password=password&processOnlyUnseenMessages=true&consumer.delay=30000").process(new MyTransform());

               

              I tried using pop3 protocol, it is giving AuthenticationFailedException.

               

              Any tips please.

               

              Cheers,

              Dav