2 Replies Latest reply on Nov 11, 2009 1:20 PM by Gert Vanthienen

    POM settings for JMS consumer bundle

    Lekan Omotayo Expert

      Hi,

       

      I am trying to create an OSGI bundle that will consumer messages off a broker's queue.

       

      I used the servicemix-jms-provider-endpoint archetype to create a maven project in my eclipse but it could resolve a maven plugin

       

      Unable to get resource 'org.apache.servicemix.tooling:jbi-maven-plugin:pom:4.1.0-psc-01-00M2' from repository central (http://repo1.maven.org/maven2) Unable to locate resource in repository

       

      How do I resolve this?

       

      Is there an example showing how to use maven to setup jms endpoints?

       

      kr.

        • 1. Re: POM settings for JMS consumer bundle
          Joe Luo Novice

          I guess you was referring to "servicemix-jms-provider-service-unit" archetype by saying "servicemix-jms-provider-endpoint archetype"?

           

          If yes, then the servicemix-jms-provider-service-unit archetype creates a JBI service unit and you will have to build a SA in order to deploy it to the container.

           

          You might want to create a camel osgi bundle to consume messages from a queue by creating a camel-jms consumer endpoint with camel route like:

          from("jms:queue:inputQueue").to("log:ExampleLog");

          and you could use servicemix-osgi-camel-archetype 2009.02.0.0-fuse version for it.

          • 2. Re: POM settings for JMS consumer bundle
            Gert Vanthienen Novice

            L.S.,

             

            That archetype references a version that should only have been used for internal purposes.  Could you provide us with the build log from running the archetype or the command you were using to get this result so we can remove the archetype again from the public repositories?

             

            To get around this issue yourself, you can always try specifying the archetype version 2009.01.0.3-fuse explicitly (add -DarchetypeVersion=2009.01.0.3-fuse in the command)

             

            Regards,

             

            Gert