1 Reply Latest reply on Jul 21, 2009 5:48 PM by Benjamin Seyinbour

    Problms after a JBoss AOP 2.1.3.GA  upgrade

    Benjamin Seyinbour Expert

      Given the instructions in the ReadMe-AS5.txt of the JBoss AOP 2.1.3.GA, I upgraded my Jboss-5.1.0.GA, but now, when it starts, I see the following errors:

      DEPLOYMENTS MISSING DEPENDENCIES:
       Deployment "AppClientParsingDeployer" is missing the following dependencies:
       Dependency "AspectLibrary" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'AspectLibrary' **")
       Deployment "Ejb3ClientDeployer" is missing the following dependencies:
       Dependency "AspectLibrary" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'AspectLibrary' **")
       Deployment "Ejb3Deployer" is missing the following dependencies:
       Dependency "AspectLibrary" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'AspectLibrary' **")
       Deployment "JBossClientParsingDeployer" is missing the following dependencies:
       Dependency "AppClientParsingDeployer" (should be in state "Create", but is actually in state "Configured")
       Deployment "MergedJBossClientMetaDataDeployer" is missing the following dependencies:
       Dependency "AppClientParsingDeployer" (should be in state "Create", but is actually in state "Configured")
       Deployment "WSDeployerHook_JAXRPC_EJB21" is missing the following dependencies:
       Dependency "WebServiceDeployerEJB" (should be in state "Create", but is actually in state "Configured")
       Deployment "WSDeployerHook_JAXWS_EJB3" is missing the following dependencies:
       Dependency "WebServiceDeployerEJB" (should be in state "Create", but is actually in state "Configured")
       Deployment "WebServiceDeployerEJB" is missing the following dependencies:
       Dependency "Ejb3Deployer" (should be in state "Create", but is actually in state "Configured")
       Deployment "jboss.j2ee:jar=profileservice-secured.jar,name=SecureDeploymentManager,service=EJB3_endpoint" is missing the following dependencies:
       Dependency "jboss.j2ee:jar=profileservice-secured.jar,name=SecureDeploymentManager,service=EJB3" (should be in state "Configured", but is actually in state "** NOT FOUND Depends on 'jboss.j2ee:jar=profileservice-secured.jar,name=SecureDeploymentManager,service=EJB3' **")
       Deployment "jboss.j2ee:jar=profileservice-secured.jar,name=SecureManagementView,service=EJB3_endpoint" is missing the following dependencies:
       Dependency "jboss.j2ee:jar=profileservice-secured.jar,name=SecureManagementView,service=EJB3" (should be in state "Configured", but is actually in state "** NOT FOUND Depends on 'jboss.j2ee:jar=profileservice-secured.jar,name=SecureManagementView,service=EJB3' **")
       Deployment "jboss.j2ee:jar=profileservice-secured.jar,name=SecureProfileService,service=EJB3_endpoint" is missing the following dependencies:
       Dependency "jboss.j2ee:jar=profileservice-secured.jar,name=SecureProfileService,service=EJB3" (should be in state "Configured", but is actually in state "** NOT FOUND Depends on 'jboss.j2ee:jar=profileservice-secured.jar,name=SecureProfileService,service=EJB3' **")
      
      DEPLOYMENTS IN ERROR:
       Deployment "jboss.j2ee:jar=profileservice-secured.jar,name=SecureManagementView,service=EJB3" is in error due to the following reason(s): ** NOT FOUND Depends on 'jboss.j2ee:jar=profileservice-secured.jar,name=SecureManagementView,service=EJB3' **
       Deployment "AspectLibrary" is in error due to the following reason(s): ** NOT FOUND Depends on 'AspectLibrary' **
       Deployment "jboss.j2ee:jar=profileservice-secured.jar,name=SecureProfileService,service=EJB3" is in error due to the following reason(s): ** NOT FOUND Depends on 'jboss.j2ee:jar=profileservice-secured.jar,name=SecureProfileService,service=EJB3' **
       Deployment "jboss.j2ee:jar=profileservice-secured.jar,name=SecureDeploymentManager,service=EJB3" is in error due to the following reason(s): ** NOT FOUND Depends on 'jboss.j2ee:jar=profileservice-secured.jar,name=SecureDeploymentManager,service=EJB3' **
      
      


      I didn't have the problems before the upgrade.

      Any ideas, anyone?


      Thanks

        • 1. Re: Problms after a JBoss AOP 2.1.3.GA  upgrade
          Benjamin Seyinbour Expert

          I hope that I have not spoken too soon but JBoss now starts without the aforementioned errors.

          When I compared the files in JBossAS before and after the upgrade, I found that the following files were missing in the JBoss AOP 2.1.3.GA upgraded JBoss-5.1.0.GA:

          /jboss-aop-jboss5.deployer/META-INF/jboss-aspect-library-jboss-beans.xml
          /jboss-aop-jboss5.deployer/META-INF/MANIFEST.MF
          /jboss-aop-jboss5.deployer/base-aspects.xml
          /jboss-aop-jboss5.deployer/jboss-aspect-library.jar
          

          Copying them back, solve the problems. So before you upgrade, manually copy these files to a directory outside JBoss and copy them back into the jboss-aop-jboss5.deployer directory after the upgrade.