1 Reply Latest reply on Jan 8, 2010 6:54 AM by Ulhas Bhole

    Using WSDL 2.0 in a CXF JBI component

    Lekan Omotayo Expert

      I am trying to deploy a servicemix-cxf-bc JBI component on FUSE ESB. I have a wsdl 2.0 file I intend to use, however, I got this error while trying to deploy my application

       

      org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 6 in XML document from URL bundleentry://235.fwk17153368/META-INF/spring/beans.xml is invalid; nested exception is org.xml.sax.SAXParseException: cvc-elt.1: Cannot find the declaration of element 'wsdl:definitions'.

       

      It seems Fuse WSDL validator is looking for the WSDL1.1 root document (definitions) which is no longer used in 2.0. Does this mean 2.0 isnt supported on Fuse yet?

       

      Regards.