0 Replies Latest reply on Mar 9, 2010 6:00 AM by Daffy Duck

    4.2.0 too buggy: stick with 4.1.0-psc-01

    Daffy Duck Novice

      Ok

       

      These last days I've posted several threads in this forum regarding issues encountered when trying to migrate a set of bundles from 4.1.0-psc-01 to 4.2.0.

       

      To sum up the most important ones:

      - ESB 4.2.0 - No component found with scheme: cxf error

      - ESB 4.2.0 - CXF - Provider org.apache.axis2.jaxws.spi.Provider not found

       

      These issues are blocking ones (weird behaviour after installing some features or/and restarting the ESB, cxf component not found by Camel, CXF issues dealing with a mysterious org.apache.axis2.jaxws.spi.Provider provider and so on).

       

      I have to stick with previous, not production-ready, FUSE ESB release hoping next release will fix all of that.

       

      Regards,

      CM

       

       

       

      Update 03/09:

      Thanks to the support of some Progress guys it seems all these issues are now solved. For people interested: it appears there may be some conflicts if you make use of some features (e.g.: camel-osgi). Refer this thread for details: http://fusesource.com/forums/thread.jspa?threadID=1688&tstart=0

       

      Edited by: concombre masqué on Mar 9, 2010 10:56 AM