1 Reply Latest reply on Mar 11, 2010 10:39 PM by Freeman(Yue) Fang

    Maven repositories org.ops4j.pax.url.mvn.cfg

    Some Developer Newbie



      I am quite new to the fuse, and i'm trying the 4.2 version.

      I noticed that in order to install features, the console does not use the maven repositories and mirrors that are configured in my maven conf/settings.xml file.


      In my maven settings file, i have a nexus server that is configured to centralize the maven repositories configuration for all our maven clients. The Nexus server contains most of the repositories that are in the /etc/org.ops4j.pax.url.mvn.cfg, but by default, these are ignored. When I try to install the webconsole feature, I get an error for some unresolvable jars.


      When I set the first url in the /etc/org.ops4j.pax.url.mvn.cfg to the published group from our nexus server, then the feature:install works.


      However this same group was already in my conf/settings.xml file. Why does this configuration ignore that one?

      I have the M2_HOME variable set correctly.


      Also, the local repository is taken from my settings.xml file. Why can't this be done for the org.ops4j.pax.url.mvn.repositories property?

      Or is this a behaviour that is required for some other reason?


      This thread is about the same as in thread:




      However this only confirms that it would be better that the features install would use the configuration used in the maven conf/settings.xml instead of using it's own set of url's.

      I guess that would make it an official "enhancement request".


      Edited by: some.java.developer on Mar 11, 2010 2:55 AM