1 Reply Latest reply on Mar 13, 2010 1:11 AM by Freeman(Yue) Fang

    deploying jpi-osgi example wsdi-first-cxfse-bundle only

    Andrew Whelan Newbie

      Hello,

       

      I am messing around with the examples/jpa-osgi example that comes with the distribution and have a question.

      I want to deploy the wsdi-first-cxfse-bundle  of the jpa-osgi example by itself as an osgi bundle.

       

      Out of the box we can build the entire jpa-osgi example with a "mvn install" at the top level.

       

      If I then try to do the following

      osgi:install -s mvn:org.apache.servicemix.examples.jpa-osgi/wsdl-first-cxfse-bundle

       

      I get the following error:

      The bundle could not be resolved. Reason: Missing Constraint: Import-Package: org.hsqldb; version="0.0.0"

       

      My question is simply "why is it having trouble resolving the org.hsqldb import"?

      It is included in the Import-Package of the pom.

       

      Thanks

      -Andrew

        • 1. Re: deploying jpi-osgi example wsdi-first-cxfse-bundle only
          Freeman(Yue) Fang Master

          Hi,

           

          The error comes from you didn't install  hsqldb/hsqldb/1.8.0.7.

          That's why we provide examples-jpa-osgi feature for users, which include all necessary bundles for this example, saving lots of your time to figure out what's needed and install manually.

           

          Why you just want to deploy  jpi-osgi example wsdi-first-cxfse-bundle only? I believe you will encounter more package resolve problem this way.

           

          So just use examples-jpa-osgi feature.

           

          Freeman