3 Replies Latest reply on Apr 16, 2010 5:19 AM by Claus Ibsen

    Camel-juel Feature

    Azda L Newbie

      I can't really figure out how to enter a bug for Fuse ESB, but installing the camel-juel feature in Fuse 4.2 doesn't work.  I get:

       

      "Could not start bundle mvn:org.apache.camel/camel-juel/2.2.0-fuse-01-00 in feature(s) camel-juel-2.2.0-fuse-01-00: The bundle could not be resolved. Reason: Missing Constraint: Import-Package: javax.el; version="[1.0.0,2.0.0)"

       

      I don't think I'm doing anything wrong, just features:install camel-juel

        • 1. Re: Camel-juel Feature
          Willem Jiang Master

          I can reproduce the error on my box. It looks like camel-juel wants to input the package of "javax.el" which version is [1.0, 2), and geronimo-el_1.0_spec can't exports the "javax.el" with the version 1.0.1, because servicemix already has this

          package, OPS4J Pax Web - Jsp Support (135): javax.el; version=2.1.0.

           

          You can work around this issue by change the camel-juel.jar's META-INFO/MANIFEST.MF to let it import the "javax.el" with the version range to be [2.0, 3).

          • 2. Re: Camel-juel Feature
            Danny Kruitbosch Newbie

            Hi,

             

            I'm having the same issue. But where can I find the camel-juel.jar, so I can implement the workaround? I'm using the binary distribution of fuse-esb 4.2.

             

            And when is this going to be fixed?

             

            Regards,

             

            Danny

            • 3. Re: Camel-juel Feature
              Claus Ibsen Master

              CAMEL-2615 is the JIRA ticket for this issue.

               

              It has been fixed, and will be included in the next FUSE ESB / FUSE MR release.