4 Replies Latest reply on Apr 13, 2010 2:00 PM by Sandeep Sheth

    Fuse ESB 4.2 Installation dependencies

    Sandeep Sheth Newbie

      I did not find any documentation related to installation of Fuse ESB 4.2.

      I unzipped the downloaded file and ran ServiceMix.bat from the bin directory.

      I have Maven installed on my machine. Do I need to install anything else before starting FUSE ESB 4.2? ServiceMix 3.3 runs on my m/c without any problem.

       

      Here is the error I am getting:

      Could not create framework: java.lang.NoSuchMethodError: org.eclipse.osgi.framework.internal.core.FrameworkProperties.inUse()Z

      java.lang.NoSuchMethodError: org.eclipse.osgi.framework.internal.core.FrameworkProperties.inUse()Z

              at org.eclipse.osgi.launch.Equinox.(Equinox.java:41)

              at org.eclipse.osgi.launch.EquinoxFactory.newFramework(EquinoxFactory.ja

      va:24)

              at org.apache.felix.karaf.main.Main.launch(Main.java:212)

              at org.apache.felix.karaf.main.Main.main(Main.java:325)