2 Replies Latest reply on Jun 2, 2005 7:45 AM by Rick Wang

    ResultSetInPool

    topicfun Newbie

      Hi!

      Sorry my silly question but I am not able to find the ResultSetInPool.class in any jar files of jboss....
      Could somebody write a jar file's name in Jboss4.0 where this class is located?

      Thanks!
      topicfun

        • 1. Re: ResultSetInPool
          topicfun Newbie

          I need it beacuse:

          The following code works with Jboss3.2.1 properly:

          ResultSet rest = prepStmt.executeQuery();
          while (rest.next()){
          blob = ((OracleResultSet)rest).getBLOB(3);

          but with Jboss4.0 one exception is thrown.
          I have searched for some solution in topics and I found the following solution:
          blob = ((OracleResultSet)(((ResultSetInPool)rest).getUnderlyingResultSet())).getBLOB(3);

          But my problem is that I am not able to find the ResultSetInPool class in the jars. Has it existed yet? How could I solve this OracleResultSet problem?

          • 2. Re: ResultSetInPool
            Rick Wang Newbie

            You can find it in ofbiz.org. But I have tried it, it still doesn't work.