7 Replies Latest reply on Aug 15, 2010 11:07 PM by jessica leahy

    Dependencies missing artifact

    marc bannink Newbie

      So i've followed trenamans video's 1, 2. I've noticed that at least in nr 2 there are differences regarding fuse versions. but i'm not really the type that would give up that easily so i've overcome those issues and went on to nr 3.

       

      First i have to say that i'm not really a maven kind of guy. I do see the good use of it and since it's more or less needed for developing with Fuse i kind of need to learn it.

       

      I am using eclipse 3.5, using m2eclipse

       

      Maven version: 2.0.9

      Java version: 1.6.0_15

      OS name: "mac os x" version: "10.6.1" arch: "x86_64" Family: "mac"

       

      So far the info. now the problem.

      During demo 3 Adrian talks about adding dependencies to the pom.xml.

      more specific jaxb-api, jaxws-api and geronimo-ws-metadata.

       

      unfortunately when i add the jaxws and geronimo eclipse starts complaining about missing artifacts.

       

      Missing artifact javax.jws:jsr181:jar:1.0:compile

      Missing artifact org.apache.geronimo.specs:geronimo-ws-metadata_2.0_spec:bundle:1.1.3:compile

       

      my guess would be that i'm missing some libraries, or am missing some repositories in my settings.xml where i could find the missing libraries/artifacts. or what could be the solution to this faulty pom?

       

      any help would be gladly appreciated.

       

      Edited by: maqish on May 15, 2010 6:57 PM